summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2019-12-07 12:06:09 -0800
committerPatrick McLean <chutzpah@gentoo.org>2019-12-07 13:55:29 -0800
commit2edb3dcb57a562191f7e9f79d09bdea3b6d18e9c (patch)
treed4e478f6abafd5b8ad947a624a7c7c903d2b2aca /dev-python/intreehooks/intreehooks-1.0.ebuild
parentsci-mathematics/rstudio: [QA] Fix AbsoluteSymlink (diff)
downloadgentoo-2edb3dcb57a562191f7e9f79d09bdea3b6d18e9c.tar.gz
gentoo-2edb3dcb57a562191f7e9f79d09bdea3b6d18e9c.tar.bz2
gentoo-2edb3dcb57a562191f7e9f79d09bdea3b6d18e9c.zip
dev-python/intreehooks: New package
Package-Manager: Portage-2.3.81, Repoman-2.3.20 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-python/intreehooks/intreehooks-1.0.ebuild')
-rw-r--r--dev-python/intreehooks/intreehooks-1.0.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/intreehooks/intreehooks-1.0.ebuild b/dev-python/intreehooks/intreehooks-1.0.ebuild
new file mode 100644
index 000000000000..a2471a84947a
--- /dev/null
+++ b/dev-python/intreehooks/intreehooks-1.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7,8} pypy{,3} )
+inherit distutils-r1
+
+DESCRIPTION="Load a PEP 517 backend from inside the source tree"
+HOMEPAGE="https://pypi.org/project/intreehooks https://github.com/takluyver/intreehooks"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+RDEPEND="
+ dev-python/toml[${PYTHON_USEDEP}]
+"
+BDEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # replace pytoml with toml
+ sed -e 's:pytoml:toml:' \
+ -i setup.py intreehooks.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+ local -a DOCS=( README.rst )
+ use examples && dodoc -r examples
+
+ distutils-r1_python_install_all
+}