summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2022-03-30 17:46:11 -0700
committerPatrick McLean <chutzpah@gentoo.org>2022-03-30 18:28:06 -0700
commit16e83ae0c72ee13e744f8967a7bf694e3659e944 (patch)
treec0b499188e50618c34473d421ea3155c43adb36d /dev-python/ioflo
parentdev-python/raet: enable py3.10 (diff)
downloadgentoo-16e83ae0c72ee13e744f8967a7bf694e3659e944.tar.gz
gentoo-16e83ae0c72ee13e744f8967a7bf694e3659e944.tar.bz2
gentoo-16e83ae0c72ee13e744f8967a7bf694e3659e944.zip
dev-python/ioflo: update EAPI 7 -> 8, add py3.10
Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-python/ioflo')
-rw-r--r--dev-python/ioflo/ioflo-2.0.2-r2.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/ioflo/ioflo-2.0.2-r2.ebuild b/dev-python/ioflo/ioflo-2.0.2-r2.ebuild
new file mode 100644
index 000000000000..21686b5e17be
--- /dev/null
+++ b/dev-python/ioflo/ioflo-2.0.2-r2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Automated Reasoning Engine and Flow Based Programming Framework"
+HOMEPAGE="https://github.com/ioflo/ioflo/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND="
+ $(python_gen_cond_dep '>=dev-lang/python-3.7.4' python3_7)
+"
+BDEPEND="${RDEPEND}
+ test? (
+ dev-python/pytest-salt-factories[${PYTHON_USEDEP}]
+ app-admin/salt[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/ioflo-1.7.8-network-test.patch"
+ "${FILESDIR}/ioflo-2.0.2-python39.patch"
+ "${FILESDIR}/ioflo-2.0.2-tests.patch"
+ "${FILESDIR}/ioflo-2.0.2-py310.patch"
+)
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ sed -e 's:"setuptools_git[^"]*",::' -i setup.py || die
+ distutils-r1_python_prepare_all
+}