summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/ipy
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/ipy')
-rw-r--r--dev-python/ipy/Manifest2
-rw-r--r--dev-python/ipy/ipy-0.82a.ebuild41
-rw-r--r--dev-python/ipy/ipy-0.83.ebuild40
-rw-r--r--dev-python/ipy/metadata.xml9
4 files changed, 92 insertions, 0 deletions
diff --git a/dev-python/ipy/Manifest b/dev-python/ipy/Manifest
new file mode 100644
index 000000000000..19f3910250a7
--- /dev/null
+++ b/dev-python/ipy/Manifest
@@ -0,0 +1,2 @@
+DIST IPy-0.82a.tar.gz 31588 SHA256 edaaa5344893437aa6c1eb9c4ca966eb4b8c071761793839c7b4fc2a837fbeec SHA512 639b58c523a69205d6b63d7cceb624eb58ccf877cb8b7edede0f52a96c401dd4cdbf000dd7dca20d8c4936d9c8dbc6bb5304e0139db5e4c1106e35e2ad551430 WHIRLPOOL 2dfeb5523fb22d5ffd30cb0b446d2f40320adffbc4ab04edc9e1addb3acefc9ac9d67f78840e40435546faf303252a9f4068686807c97d9c35ed03cb2fa86d57
+DIST IPy-0.83.tar.gz 31816 SHA256 61da5a532b159b387176f6eabf11946e7458b6df8fb8b91ff1d345ca7a6edab8 SHA512 6bd69d96fa77dc4ceaf119b81c19a524b871badb37665a763a055e1c8b2ce3433c6e9534f03aa64d02e559dca2fac2c4e1d09b7fd78ed79c0fded88f803ad2de WHIRLPOOL 0f58ea88a437293ca2d89aa41c76db49cdfee4b52fe6fbae1e8dce297b59bf1309d79612283ac7691b17ddf1c7596b19a3b39c6ce157946ea8274166e1da9d9b
diff --git a/dev-python/ipy/ipy-0.82a.ebuild b/dev-python/ipy/ipy-0.82a.ebuild
new file mode 100644
index 000000000000..90f7c24563e4
--- /dev/null
+++ b/dev-python/ipy/ipy-0.82a.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} pypy )
+
+inherit distutils-r1
+
+MY_PN="IPy"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Class and tools for handling of IPv4 and IPv6 addresses and networks"
+HOMEPAGE="https://github.com/haypo/python-ipy/wiki http://pypi.python.org/pypi/IPy"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~ppc64 ~sparc x86"
+IUSE="examples"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""
+
+S="${WORKDIR}/python-${PN}-${MY_P}"
+
+python_test() {
+ # doctests for py3 unaltered read py2 files from "${S}" causing total failure
+ # https://github.com/haypo/python-ipy/issues/17
+ cp -r test_doc.py README test "${BUILD_DIR}" || die
+ pushd "${BUILD_DIR}" > /dev/null || die
+ "${PYTHON}" test/test_IPy.py || die "Tests fail with ${EPYTHON}"
+ "${PYTHON}" test_doc.py || die "Doctests fail with ${EPYTHON}"
+ popd > /dev/null || die
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( example/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/ipy/ipy-0.83.ebuild b/dev-python/ipy/ipy-0.83.ebuild
new file mode 100644
index 000000000000..c3449d8653a5
--- /dev/null
+++ b/dev-python/ipy/ipy-0.83.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} pypy )
+
+inherit distutils-r1
+
+MY_PN="IPy"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Class and tools for handling of IPv4 and IPv6 addresses and networks"
+HOMEPAGE="https://github.com/haypo/python-ipy/wiki http://pypi.python.org/pypi/IPy"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="examples"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+python_test() {
+ # 1 test fail under pypy, persistent from 0.82a, not a regression.
+ cp -r test_doc.py README test "${BUILD_DIR}" || die
+ pushd "${BUILD_DIR}" > /dev/null || die
+ "${PYTHON}" test/test_IPy.py || die "Tests fail with ${EPYTHON}"
+ "${PYTHON}" test_doc.py || die "Doctests fail with ${EPYTHON}"
+ popd > /dev/null || die
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( example/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/ipy/metadata.xml b/dev-python/ipy/metadata.xml
new file mode 100644
index 000000000000..8430480ce362
--- /dev/null
+++ b/dev-python/ipy/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="pypi">IPy</remote-id>
+ <remote-id type="github">haypo/python-ipy</remote-id>
+ </upstream>
+</pkgmetadata>