summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-08-10 10:24:36 +0200
committerMichał Górny <mgorny@gentoo.org>2022-08-10 10:52:49 +0200
commitb1a4876c48826a1b3f6e4c21002d2c9828708269 (patch)
treea85eb05062b1c5decf4602c065451b1a9793f6ba /dev-python/ipykernel
parentdev-libs/libstrophe: remove explicit default impl of src_test (diff)
downloadgentoo-b1a4876c48826a1b3f6e4c21002d2c9828708269.tar.gz
gentoo-b1a4876c48826a1b3f6e4c21002d2c9828708269.tar.bz2
gentoo-b1a4876c48826a1b3f6e4c21002d2c9828708269.zip
dev-python/ipykernel: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/ipykernel')
-rw-r--r--dev-python/ipykernel/Manifest1
-rw-r--r--dev-python/ipykernel/ipykernel-6.15.0.ebuild66
2 files changed, 0 insertions, 67 deletions
diff --git a/dev-python/ipykernel/Manifest b/dev-python/ipykernel/Manifest
index d9ef76bcdb6a..95dc098ddd8e 100644
--- a/dev-python/ipykernel/Manifest
+++ b/dev-python/ipykernel/Manifest
@@ -1,2 +1 @@
-DIST ipykernel-6.15.0.tar.gz 134691 BLAKE2B ba3eefde9f1023ccf83c63a35dd99fdfebc0bda0d4f73e6477a098564c0a9fb7c0082413ae31dc8cf423339c3e44887bcf5253355c13630619f44b18d19e9913 SHA512 a6533f094d18d32a02e8de5638fdabb9f647edc9a512e609de3bb1d80f5592acef4e930d879bf79bde7a0ca23945d9eb112d841f2305204fac9f4c672b5315ac
DIST ipykernel-6.15.1.tar.gz 133140 BLAKE2B 7d63b55f2b8d883234258106b8239cf77031336ce6e7e38234490a031fc4a56861788210fdb2acd0f895e4df43257b0339ef1592e12d33b441e4ba9061acbd08 SHA512 10f2390a4edafea89fcc049d5e07ef542418a3a7b076efec1f02bc0a787e01280624cc543bb60604478cae63b58a86d031b549a6f872c7a8530043d670dbdc0e
diff --git a/dev-python/ipykernel/ipykernel-6.15.0.ebuild b/dev-python/ipykernel/ipykernel-6.15.0.ebuild
deleted file mode 100644
index 01c1b618e4b0..000000000000
--- a/dev-python/ipykernel/ipykernel-6.15.0.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=hatchling
-PYTHON_COMPAT=( python3_{8..10} )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1
-
-DESCRIPTION="IPython Kernel for Jupyter"
-HOMEPAGE="https://github.com/ipython/ipykernel"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 hppa ~ia64 ppc ppc64 ~riscv ~s390 sparc x86"
-
-RDEPEND="
- >=dev-python/debugpy-1.0[${PYTHON_USEDEP}]
- >=dev-python/ipython-7.23.1[${PYTHON_USEDEP}]
- >=dev-python/jupyter_client-6.1.12[${PYTHON_USEDEP}]
- >=dev-python/matplotlib-inline-0.1[${PYTHON_USEDEP}]
- dev-python/nest_asyncio[${PYTHON_USEDEP}]
- dev-python/packaging[${PYTHON_USEDEP}]
- dev-python/psutil[${PYTHON_USEDEP}]
- >=dev-python/pyzmq-17[${PYTHON_USEDEP}]
- >=dev-python/traitlets-5.1.0[${PYTHON_USEDEP}]
- >=www-servers/tornado-6.1[${PYTHON_USEDEP}]
-"
-# RDEPEND seems specifically needed in BDEPEND, at least jupyter
-# bug #816486
-BDEPEND="
- ${RDEPEND}
- test? (
- dev-python/flaky[${PYTHON_USEDEP}]
- dev-python/pytest-timeout[${PYTHON_USEDEP}]
- dev-python/ipyparallel[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-EPYTEST_DESELECT=(
- # TODO
- ipykernel/inprocess/tests/test_kernel.py::InProcessKernelTestCase::test_pylab
- ipykernel/tests/test_debugger.py::test_attach_debug
- ipykernel/tests/test_debugger.py::test_breakpoint_in_cell_with_leading_empty_lines
- ipykernel/tests/test_debugger.py::test_rich_inspect_at_breakpoint
- ipykernel/tests/test_debugger.py::test_rich_inspect_not_at_breakpoint
- ipykernel/tests/test_debugger.py::test_set_breakpoints
- ipykernel/tests/test_debugger.py::test_stop_on_breakpoint
-)
-
-src_prepare() {
- sed -i -e 's:^TIMEOUT = .*:TIMEOUT = 120:' ipykernel/tests/*.py || die
- distutils-r1_src_prepare
-}
-
-python_compile() {
- distutils-r1_python_compile
- # Use python3 in kernel.json configuration, bug #784764
- sed -i -e '/python3.[0-9]\+/s//python3/' \
- "${BUILD_DIR}/install${EPREFIX}/usr/share/jupyter/kernels/python3/kernel.json" || die
-}