summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-11-25 13:25:05 +0100
committerMichał Górny <mgorny@gentoo.org>2019-11-25 13:35:11 +0100
commitf7595ec5e0419cc5f2373a3395e5182baa9f7320 (patch)
tree0f913111691db0542db61d6c7c8c053ed24f6130 /dev-python/jaraco-packaging
parentdev-python/jaraco-functools: Use distutils_enable_sphinx (diff)
downloadgentoo-f7595ec5e0419cc5f2373a3395e5182baa9f7320.tar.gz
gentoo-f7595ec5e0419cc5f2373a3395e5182baa9f7320.tar.bz2
gentoo-f7595ec5e0419cc5f2373a3395e5182baa9f7320.zip
dev-python/jaraco-packaging: Use distutils_enable_sphinx
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/jaraco-packaging')
-rw-r--r--dev-python/jaraco-packaging/jaraco-packaging-6.2-r1.ebuild30
1 files changed, 5 insertions, 25 deletions
diff --git a/dev-python/jaraco-packaging/jaraco-packaging-6.2-r1.ebuild b/dev-python/jaraco-packaging/jaraco-packaging-6.2-r1.ebuild
index e3e5f83ada4f..79852d7bffa4 100644
--- a/dev-python/jaraco-packaging/jaraco-packaging-6.2-r1.ebuild
+++ b/dev-python/jaraco-packaging/jaraco-packaging-6.2-r1.ebuild
@@ -11,11 +11,13 @@ MY_PN="${PN/-/.}"
DESCRIPTION="Tools to supplement packaging Python releases"
HOMEPAGE="https://github.com/jaraco/jaraco.packaging"
SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+S="${WORKDIR}/${MY_PN}-${PV}"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
-IUSE="doc test"
+IUSE="test"
+RESTRICT="!test? ( test )"
RDEPEND="
dev-python/importlib_metadata[${PYTHON_USEDEP}]
@@ -24,28 +26,14 @@ RDEPEND="
"
DEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
- doc? (
- $(python_gen_any_dep '
- >=dev-python/rst-linker-1.9[${PYTHON_USEDEP}]
- dev-python/sphinx[${PYTHON_USEDEP}]
- ')
- )
test? (
${RDEPEND}
>=dev-python/pytest-2.8[${PYTHON_USEDEP}]
)
"
-RESTRICT="!test? ( test )"
-
-S="${WORKDIR}/${MY_PN}-${PV}"
-
-python_check_deps() {
- use doc || return 0
-
- has_version ">=dev-python/rst-linker-1.9[${PYTHON_USEDEP}]" && \
- has_version "dev-python/sphinx[${PYTHON_USEDEP}]"
-}
+distutils_enable_sphinx docs \
+ ">=dev-python/rst-linker-1.9"
python_prepare_all() {
# avoid a setuptools_scm dependency
@@ -56,14 +44,6 @@ python_prepare_all() {
distutils-r1_python_prepare_all
}
-python_compile_all() {
- if use doc; then
- cd docs || die
- sphinx-build . _build/html || die
- HTML_DOCS=( docs/_build/html/. )
- fi
-}
-
python_test() {
# Skip one test which requires network access
# Override pytest options to skip flake8