summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-01-27 09:26:13 +0100
committerMichał Górny <mgorny@gentoo.org>2023-01-27 11:51:28 +0100
commit1564560052deff2c1524b3ee93b9535bba65795b (patch)
tree6f8cf5bbc8e898eb76583eb98ef251d399765484 /dev-python/jupyter_client
parentdev-python/qiskit-terra: Bump to 0.23.0 (diff)
downloadgentoo-1564560052deff2c1524b3ee93b9535bba65795b.tar.gz
gentoo-1564560052deff2c1524b3ee93b9535bba65795b.tar.bz2
gentoo-1564560052deff2c1524b3ee93b9535bba65795b.zip
dev-python/jupyter_client: Bump to 8.0.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/jupyter_client')
-rw-r--r--dev-python/jupyter_client/Manifest1
-rw-r--r--dev-python/jupyter_client/jupyter_client-8.0.1.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/jupyter_client/Manifest b/dev-python/jupyter_client/Manifest
index aad6ba774196..3160ccdaafb2 100644
--- a/dev-python/jupyter_client/Manifest
+++ b/dev-python/jupyter_client/Manifest
@@ -1,2 +1,3 @@
DIST jupyter_client-7.4.8.tar.gz 328958 BLAKE2B d05976563c5550ba46a9525c76dae325a107a664c7cc6711fc43333ea9ee747c4b69084e1f4d3118b0baa69bd42781bdd49ce59bf6e608f5520e82e295ffff2c SHA512 dc7eed72ac6c820448e6d8a96c2bee7964706ba608ecaddc8b8aa17f33727ffc04c5a509cd8d7ee78876ce646fc6a508bacdc7b07473555efdad9dd2960ad089
DIST jupyter_client-7.4.9.tar.gz 329115 BLAKE2B 8b43b237ac79bc51e40e403cf4a3ada18d03437094dc1dd9b9988adb1bcfbc56ba4b2373d3dd858df583b723723127f934c01544f3d6a576886b012364674f0f SHA512 0de91309ffddd2da50ae69bff4f7ecd741398171982f66488e6367d78388c6844b353bed1834684fa4af890364120ce09f2fa6b3ed7778c501058ae558439969
+DIST jupyter_client-8.0.1.tar.gz 333329 BLAKE2B 90be4e3d0271d8fb957e2766e523d333ade3811877aabe55f4768c789cab2782ba6594943d040a23efedb266f2f873b51cd37bc48a9e2603618fb074ca2c1d48 SHA512 c7c643f71e25bbd2b6742e20a6609253517704ca15360ad7f4494e8c96155daa331e218d073f83bc75f23f1b242e626313da95fe1766c29d07e10cd65b7046f0
diff --git a/dev-python/jupyter_client/jupyter_client-8.0.1.ebuild b/dev-python/jupyter_client/jupyter_client-8.0.1.ebuild
new file mode 100644
index 000000000000..c930f1f2ad9c
--- /dev/null
+++ b/dev-python/jupyter_client/jupyter_client-8.0.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Jupyter protocol implementation and client libraries"
+HOMEPAGE="
+ https://jupyter.org/
+ https://github.com/jupyter/jupyter_client/
+ https://pypi.org/project/jupyter-client/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ia64 ~loong ~ppc ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/jupyter_core-5.1[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.8.2[${PYTHON_USEDEP}]
+ >=dev-python/pyzmq-23.0[${PYTHON_USEDEP}]
+ >=dev-python/tornado-6.0[${PYTHON_USEDEP}]
+ dev-python/traitlets[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/importlib_metadata-4.8.3[${PYTHON_USEDEP}]
+ ' 3.{8,9})
+"
+BDEPEND="
+ test? (
+ >=dev-python/ipykernel-6.14[${PYTHON_USEDEP}]
+ >=dev-python/pytest-asyncio-0.18[${PYTHON_USEDEP}]
+ >=dev-python/pytest_jupyter-0.4.1[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # TODO: times out
+ tests/test_client.py::TestAsyncKernelClient::test_input_request
+ # TODO
+ tests/test_multikernelmanager.py::TestKernelManager::test_tcp_cinfo
+)