summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-04-14 05:25:11 +0200
committerMichał Górny <mgorny@gentoo.org>2023-04-14 05:59:20 +0200
commit62f753be1d5ae9b61546b660b305cd475a2a675b (patch)
treed40d89764cab46a894a15d81925cb4697865539e /dev-python/jupyterlab-server
parentdev-python/jupyter_client: Bump to 8.2.0 (diff)
downloadgentoo-62f753be1d5ae9b61546b660b305cd475a2a675b.tar.gz
gentoo-62f753be1d5ae9b61546b660b305cd475a2a675b.tar.bz2
gentoo-62f753be1d5ae9b61546b660b305cd475a2a675b.zip
dev-python/jupyterlab-server: Bump to 2.22.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/jupyterlab-server')
-rw-r--r--dev-python/jupyterlab-server/Manifest1
-rw-r--r--dev-python/jupyterlab-server/jupyterlab-server-2.22.1.ebuild69
2 files changed, 70 insertions, 0 deletions
diff --git a/dev-python/jupyterlab-server/Manifest b/dev-python/jupyterlab-server/Manifest
index 0cd9d05e5616..8710c881f514 100644
--- a/dev-python/jupyterlab-server/Manifest
+++ b/dev-python/jupyterlab-server/Manifest
@@ -1 +1,2 @@
DIST jupyterlab_server-2.22.0.tar.gz 71374 BLAKE2B da27d6fb6d22db4aacd4c6c7a96ca748c5ba95d6b357fb45aa3383642b23bff7b61298eb01b8a80073080248e06fae35e04b1a7e4144018e84a6b548937ad0e6 SHA512 96484afe03a23f4aa6492b15e64b3f874b144af371d65c94693b708f9152e2762f98f0dea2b7464f8240740f4be56b2cd61a8869ef001521bbb4748dd0fc7005
+DIST jupyterlab_server-2.22.1.tar.gz 71443 BLAKE2B 37273cb3251f358607936bb723e4c9b7d15aa9c6c0193d9cc14b5cf2ed07a5a50d8588b42c243193e3efb30cf0e000c6ea19f725e0f2c943eaf56d3b161dcbd9 SHA512 01d223b59ac906b4bfd5cc46db375abe67ffd518422625cae06e08266bee908dcf34b4544ff8f12aa45c9ac00a6473e164735423a9c55290f922a0e2d930eaa9
diff --git a/dev-python/jupyterlab-server/jupyterlab-server-2.22.1.ebuild b/dev-python/jupyterlab-server/jupyterlab-server-2.22.1.ebuild
new file mode 100644
index 000000000000..b3b9f406c2a3
--- /dev/null
+++ b/dev-python/jupyterlab-server/jupyterlab-server-2.22.1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+DISTUTILS_USE_PEP517=hatchling
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Server components for JupyterLab and JupyterLab like applications"
+HOMEPAGE="
+ https://jupyter.org/
+ https://github.com/jupyterlab/jupyterlab_server/
+ https://pypi.org/project/jupyterlab-server/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/Babel-2.10[${PYTHON_USEDEP}]
+ >=dev-python/jinja-3.0.3[${PYTHON_USEDEP}]
+ >=dev-python/json5-0.9.0[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-3.0.1[${PYTHON_USEDEP}]
+ >=dev-python/packaging-21.3[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.28[${PYTHON_USEDEP}]
+ >=dev-python/jupyter-server-1.21[${PYTHON_USEDEP}]
+ <dev-python/jupyter-server-3[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/importlib_metadata-4.8.3[${PYTHON_USEDEP}]
+ ' 3.9)
+"
+
+BDEPEND="
+ test? (
+ dev-python/ipykernel[${PYTHON_USEDEP}]
+ dev-python/jupyter-server[${PYTHON_USEDEP}]
+ <dev-python/openapi-core-0.17[${PYTHON_USEDEP}]
+ >=dev-python/openapi-core-0.16.1[${PYTHON_USEDEP}]
+ <dev-python/openapi-spec-validator-0.6[${PYTHON_USEDEP}]
+ >=dev-python/openapi-spec-validator-0.5.1[${PYTHON_USEDEP}]
+ dev-python/pytest-jupyter[${PYTHON_USEDEP}]
+ dev-python/pytest-tornasync[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ dev-python/ruamel-yaml[${PYTHON_USEDEP}]
+ dev-python/strict-rfc3339[${PYTHON_USEDEP}]
+ dev-python/requests-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+# TODO: package autodoc_traits
+#distutils_enable_sphinx docs/source dev-python/pydata-sphinx-theme dev-python/myst-parser
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ tests/test_translation_api.py
+ )
+
+ EPYTEST_DESELECT=(
+ # Fails if terminal not available
+ tests/test_labapp.py::test_page_config
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p pytest_tornasync.plugin
+}