summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-01-27 21:05:40 +0100
committerMichał Górny <mgorny@gentoo.org>2023-01-27 21:09:29 +0100
commit671c2c57e4899918067c1e7cc533dd7e42fab703 (patch)
tree1b2d66bc610e13704e5ff1ea91e906b06506c6e6 /dev-python/jupyterlab
parentdev-python/jupyter_events: Remove old (diff)
downloadgentoo-671c2c57e4899918067c1e7cc533dd7e42fab703.tar.gz
gentoo-671c2c57e4899918067c1e7cc533dd7e42fab703.tar.bz2
gentoo-671c2c57e4899918067c1e7cc533dd7e42fab703.zip
dev-python/jupyterlab: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/jupyterlab')
-rw-r--r--dev-python/jupyterlab/Manifest2
-rw-r--r--dev-python/jupyterlab/jupyterlab-3.5.0.ebuild70
-rw-r--r--dev-python/jupyterlab/jupyterlab-3.5.2.ebuild71
3 files changed, 0 insertions, 143 deletions
diff --git a/dev-python/jupyterlab/Manifest b/dev-python/jupyterlab/Manifest
index 289bf7dce748..61ed55c0ddd2 100644
--- a/dev-python/jupyterlab/Manifest
+++ b/dev-python/jupyterlab/Manifest
@@ -1,3 +1 @@
-DIST jupyterlab-3.5.0.tar.gz 17110889 BLAKE2B 89b20734dea44419af023b88c85b243fa3f8ac0c7272600729da8690eb53cd4286d9c9bb90e95e291644de3675a9daae63898d6621cc4c21b4fc8e0d965242b4 SHA512 43b893127b5b4f1ccd472dfe9152d4ac8f89192411d1fa6045e3ecfb5f8f16819d1cf4b6fd70d9656d25d10cafff55055da98d36d2c8537d5b07e29e2d157799
-DIST jupyterlab-3.5.2.tar.gz 17111761 BLAKE2B 77c63d8842f9e58a10ed3fae3ecd9cd6b10045d3aec1e90cbc83fe40bc7d4b5cbac4eabbaac2a36c77815cd27f332a35ffdf8ea5e7fd07e95893bd5bad5c68a4 SHA512 b6a5b314fc23e4a9164085827123c19570d112519c6651453006cc18f89c1eaac74871f6e8faf9ced4c32eada72912f72b2ab3cb2ff101ef6b6e3e70601494aa
DIST jupyterlab-3.5.3.tar.gz 17114007 BLAKE2B 70d32721a2579331dd4e3481f7241f5e2c5aad6dac851f213de0ac1fc3b76667bea496bca5ea13ee562e9678d51ac45df91c5901d8d3b7dc839977d3d842e67d SHA512 fdacd34ab629da2b5c2eb23f11ba4d44d5b27872e1736850319bcabbe635d31cfa2891c1c5991b152a5c1d94221e3766a20fc91033f556d8e508374bc46d5fe2
diff --git a/dev-python/jupyterlab/jupyterlab-3.5.0.ebuild b/dev-python/jupyterlab/jupyterlab-3.5.0.ebuild
deleted file mode 100644
index a1fb5d36f127..000000000000
--- a/dev-python/jupyterlab/jupyterlab-3.5.0.ebuild
+++ /dev/null
@@ -1,70 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{9..11} )
-DISTUTILS_USE_PEP517=jupyter
-inherit distutils-r1
-
-DESCRIPTION="JupyterLab computational environment"
-HOMEPAGE="https://jupyter.org/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD MIT GPL-3 Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-BDEPEND="dev-python/jupyter_packaging[${PYTHON_USEDEP}]"
-
-RDEPEND="
- dev-python/ipython[${PYTHON_USEDEP}]
- dev-python/packaging[${PYTHON_USEDEP}]
- dev-python/jupyter_core[${PYTHON_USEDEP}]
- >=dev-python/jupyterlab_server-2.10[${PYTHON_USEDEP}]
- >=dev-python/jupyter_server-1.16[${PYTHON_USEDEP}]
- >=dev-python/nbclassic-0.2[${PYTHON_USEDEP}]
- <dev-python/notebook-7[${PYTHON_USEDEP}]
- >=dev-python/jinja-2.1[${PYTHON_USEDEP}]
- >=dev-python/tornado-6.1[${PYTHON_USEDEP}]
- dev-python/tomli[${PYTHON_USEDEP}]
- net-libs/nodejs
-"
-
-BDEPEND="test? (
- dev-python/check-manifest[${PYTHON_USEDEP}]
- dev-python/ipykernel[${PYTHON_USEDEP}]
- dev-python/jupyterlab_server[${PYTHON_USEDEP}]
- dev-python/openapi-core[${PYTHON_USEDEP}]
- dev-python/openapi-spec-validator[${PYTHON_USEDEP}]
- dev-python/pytest-console-scripts[${PYTHON_USEDEP}]
- dev-python/pytest-tornasync[${PYTHON_USEDEP}]
- dev-python/pytest-timeout[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/ruamel-yaml[${PYTHON_USEDEP}]
- dev-python/requests-cache[${PYTHON_USEDEP}]
- dev-python/strict-rfc3339[${PYTHON_USEDEP}]
- dev-python/virtualenv[${PYTHON_USEDEP}]
-)"
-
-EPYTEST_DESELECT=(
- # These tests call npm and want internet
- jupyterlab/tests/test_jupyterlab.py::TestExtension::test_uninstall_core_extension
- jupyterlab/tests/test_jupyterlab.py::TestExtension::test_install_and_uninstall_pinned_folder
- jupyterlab/tests/test_jupyterlab.py::TestExtension::test_install_and_uninstall_pinned
- jupyterlab/tests/test_jupyterlab.py::TestExtension::test_build_custom_minimal_core_config
- jupyterlab/tests/test_jupyterlab.py::TestExtension::test_build_custom
- jupyterlab/tests/test_jupyterlab.py::TestExtension::test_build_check
- jupyterlab/tests/test_jupyterlab.py::TestExtension::test_build
- jupyterlab/tests/test_build_api.py::TestBuildAPI::test_clear
- jupyterlab/tests/test_build_api.py::TestBuildAPI::test_build
-)
-
-distutils_enable_tests pytest
-# TODO: package sphinx_copybutton
-#distutils_enable_sphinx docs/source dev-python/sphinx_rtd_theme dev-python/myst_parser
-
-python_install_all() {
- distutils-r1_python_install_all
- mv "${ED}/usr/etc" "${ED}/etc" || die
-}
diff --git a/dev-python/jupyterlab/jupyterlab-3.5.2.ebuild b/dev-python/jupyterlab/jupyterlab-3.5.2.ebuild
deleted file mode 100644
index ca941f146fb3..000000000000
--- a/dev-python/jupyterlab/jupyterlab-3.5.2.ebuild
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{9..11} )
-DISTUTILS_USE_PEP517=jupyter
-inherit distutils-r1
-
-DESCRIPTION="JupyterLab computational environment"
-HOMEPAGE="https://jupyter.org/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD MIT GPL-3 Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-BDEPEND="dev-python/jupyter_packaging[${PYTHON_USEDEP}]"
-
-RDEPEND="
- dev-python/ipython[${PYTHON_USEDEP}]
- dev-python/packaging[${PYTHON_USEDEP}]
- dev-python/jupyter_core[${PYTHON_USEDEP}]
- >=dev-python/jupyterlab_server-2.10[${PYTHON_USEDEP}]
- >=dev-python/jupyter_server-1.16[${PYTHON_USEDEP}]
- >=dev-python/nbclassic-0.2[${PYTHON_USEDEP}]
- <dev-python/notebook-7[${PYTHON_USEDEP}]
- >=dev-python/jinja-2.1[${PYTHON_USEDEP}]
- >=dev-python/tornado-6.2[${PYTHON_USEDEP}]
- dev-python/tomli[${PYTHON_USEDEP}]
- net-libs/nodejs
-"
-
-BDEPEND="test? (
- dev-python/check-manifest[${PYTHON_USEDEP}]
- dev-python/ipykernel[${PYTHON_USEDEP}]
- dev-python/jupyterlab_server[${PYTHON_USEDEP}]
- dev-python/openapi-core[${PYTHON_USEDEP}]
- dev-python/openapi-spec-validator[${PYTHON_USEDEP}]
- dev-python/pytest-console-scripts[${PYTHON_USEDEP}]
- dev-python/pytest_jupyter[${PYTHON_USEDEP}]
- dev-python/pytest-tornasync[${PYTHON_USEDEP}]
- dev-python/pytest-timeout[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/ruamel-yaml[${PYTHON_USEDEP}]
- dev-python/requests-cache[${PYTHON_USEDEP}]
- dev-python/strict-rfc3339[${PYTHON_USEDEP}]
- dev-python/virtualenv[${PYTHON_USEDEP}]
-)"
-
-EPYTEST_DESELECT=(
- # These tests call npm and want internet
- jupyterlab/tests/test_jupyterlab.py::TestExtension::test_uninstall_core_extension
- jupyterlab/tests/test_jupyterlab.py::TestExtension::test_install_and_uninstall_pinned_folder
- jupyterlab/tests/test_jupyterlab.py::TestExtension::test_install_and_uninstall_pinned
- jupyterlab/tests/test_jupyterlab.py::TestExtension::test_build_custom_minimal_core_config
- jupyterlab/tests/test_jupyterlab.py::TestExtension::test_build_custom
- jupyterlab/tests/test_jupyterlab.py::TestExtension::test_build_check
- jupyterlab/tests/test_jupyterlab.py::TestExtension::test_build
- jupyterlab/tests/test_build_api.py::TestBuildAPI::test_clear
- jupyterlab/tests/test_build_api.py::TestBuildAPI::test_build
-)
-
-distutils_enable_tests pytest
-# TODO: package sphinx_copybutton
-#distutils_enable_sphinx docs/source dev-python/sphinx_rtd_theme dev-python/myst_parser
-
-python_install_all() {
- distutils-r1_python_install_all
- mv "${ED}/usr/etc" "${ED}/etc" || die
-}