summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-10-29 21:56:56 +0100
committerMichał Górny <mgorny@gentoo.org>2023-10-29 21:59:01 +0100
commit9a9134c6ac735fd653f6e75d442e8daf4d8d36c3 (patch)
treebd033decd4a2400209d8aac5a6181c88561cd5fe /dev-python/liblarch
parentmedia-gfx/mcomix: Stabilize 2.1.1-r1 amd64, #916150 (diff)
downloadgentoo-9a9134c6ac735fd653f6e75d442e8daf4d8d36c3.tar.gz
gentoo-9a9134c6ac735fd653f6e75d442e8daf4d8d36c3.tar.bz2
gentoo-9a9134c6ac735fd653f6e75d442e8daf4d8d36c3.zip
dev-python/liblarch: Bump to 3.2.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/liblarch')
-rw-r--r--dev-python/liblarch/Manifest1
-rw-r--r--dev-python/liblarch/liblarch-3.2.0.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/liblarch/Manifest b/dev-python/liblarch/Manifest
index 223e7d7688a4..641ffc51b3a2 100644
--- a/dev-python/liblarch/Manifest
+++ b/dev-python/liblarch/Manifest
@@ -1 +1,2 @@
DIST liblarch-3.1.0.tar.gz 55727 BLAKE2B 531602b43f7729f59f59394aa1dd6d3ee4ad653d4ef8802de2074c9a9746d43da1638941c1e8f2075d9092810ba680f2e01bee360c55b0826bb725d6515b31df SHA512 042a763dd12612d6630c064b5af84011f1fb908626f17f866e103743cdaabb4983f922290287b0138938488a7c9bff33680ef8157f8bbcbc166e4f4f2d008951
+DIST liblarch-3.2.0.tar.gz 56733 BLAKE2B 92bf0c51b2f16e84633c75f51ccf321c8756b154bfa76412db5ff7b1879e27f0a24f69e2be94db10c9409b0b326d5ac4477c88eaf8f1be80ef9f3390ea26f879 SHA512 d356535f2e60885249be009f7e671fcb1ee02b7d32b7abecc3805c5f6b6e231fc34be0d7a73cd9f9a68dfaae0b1cf0a5bdc54ed3075901a149d58ad6577d92ab
diff --git a/dev-python/liblarch/liblarch-3.2.0.ebuild b/dev-python/liblarch/liblarch-3.2.0.ebuild
new file mode 100644
index 000000000000..375932865f1c
--- /dev/null
+++ b/dev-python/liblarch/liblarch-3.2.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Library to handle directed acyclic graphs"
+HOMEPAGE="
+ https://wiki.gnome.org/Projects/liblarch
+ https://github.com/getting-things-gnome/liblarch/
+"
+SRC_URI="
+ https://github.com/getting-things-gnome/liblarch/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz
+"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+DEPEND="
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ x11-libs/gtk+:3[introspection]
+"
+RDEPEND="
+ ${DEPEND}
+"
+
+distutils_enable_tests pytest
+
+src_test() {
+ virtx distutils-r1_src_test
+}