summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-08-18 08:29:18 +0200
committerMichał Górny <mgorny@gentoo.org>2021-08-18 08:56:28 +0200
commit2cd7f231cc82db5b1ea1c6c1a3362e4d61cb567f (patch)
tree6f6cc38ca0aea4cb7ac8e066f0103fecd628c399 /dev-python/markdown2
parentdev-python/jellyfish: bump to 0.8.8, dropped 0.8.7 (diff)
downloadgentoo-2cd7f231cc82db5b1ea1c6c1a3362e4d61cb567f.tar.gz
gentoo-2cd7f231cc82db5b1ea1c6c1a3362e4d61cb567f.tar.bz2
gentoo-2cd7f231cc82db5b1ea1c6c1a3362e4d61cb567f.zip
dev-python/markdown2: Bump to 2.4.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/markdown2')
-rw-r--r--dev-python/markdown2/Manifest1
-rw-r--r--dev-python/markdown2/markdown2-2.4.1.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/markdown2/Manifest b/dev-python/markdown2/Manifest
index dd06515cb2da..e8eb5f021c40 100644
--- a/dev-python/markdown2/Manifest
+++ b/dev-python/markdown2/Manifest
@@ -1 +1,2 @@
DIST markdown2-2.4.0.tar.gz 96596 BLAKE2B 23fa2b05e7f26bd76b38b2c7f4fb5b3b36694b0e30ab3f168b64754f62d7d2742c5e0bfbed774a198527ad226bfe411e0ba11ddf6d0b2002670e5937750070a2 SHA512 ed523116e01121e471ee1a8ea9e8dde42a04c4c7c5170c56eed852268881f18b7b5062c43f1548fad3a84e2fbddc19c26fbf88084f6affdd11fd4d493a480cdf
+DIST markdown2-2.4.1.tar.gz 97089 BLAKE2B 62506be323a0c05060e5922b4eafbe1d0f6c2d9f81348fe5e35af8a577e0d7c26ba56cfa727fc1bb13dc3d08e7a8fe183d9ad91746dfc7a0034d025ff91c1bb9 SHA512 fa62640a135bb01b2dc82f658089c5880a3183c3b6e498ce76a27075d3045d70d7e00b9d497180a63c00cbd9ece83ebabaa8cd31ee326160d891fb422f43528e
diff --git a/dev-python/markdown2/markdown2-2.4.1.ebuild b/dev-python/markdown2/markdown2-2.4.1.ebuild
new file mode 100644
index 000000000000..8d0e570a4c21
--- /dev/null
+++ b/dev-python/markdown2/markdown2-2.4.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Python Markdown language reimplementation"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+HOMEPAGE="https://github.com/trentm/python-markdown2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="dev-python/pygments[${PYTHON_USEDEP}]"
+
+distutils_enable_tests unittest
+
+src_test() {
+ cd test || die
+ distutils-r1_src_test
+}
+
+python_test() {
+ "${EPYTHON}" -m unittest test_markdown2.py -v ||
+ die "Tests fail with ${EPYTHON}"
+}