summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetr Vaněk <arkamar@atlas.cz>2023-05-28 12:23:29 +0200
committerSam James <sam@gentoo.org>2023-05-28 12:35:27 +0100
commit5c781ffe7f0130e56cb62d5d57a27a00f75bf23a (patch)
tree9dc8ebaa11661bb3f4b5b1365d18f8f51ea0ff9c /dev-python/matrix-common
parentdev-python/pymacaroons: enable py3.12 (diff)
downloadgentoo-5c781ffe7f0130e56cb62d5d57a27a00f75bf23a.tar.gz
gentoo-5c781ffe7f0130e56cb62d5d57a27a00f75bf23a.tar.bz2
gentoo-5c781ffe7f0130e56cb62d5d57a27a00f75bf23a.zip
dev-python/matrix-common: enable py3.12
and remove unnecessary rdeps on dev-python/importlib-metadata, which is required only for older python versions. Signed-off-by: Petr Vaněk <arkamar@atlas.cz> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/matrix-common')
-rw-r--r--dev-python/matrix-common/matrix-common-1.3.0-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/matrix-common/matrix-common-1.3.0-r1.ebuild b/dev-python/matrix-common/matrix-common-1.3.0-r1.ebuild
new file mode 100644
index 000000000000..3fc65d970aa6
--- /dev/null
+++ b/dev-python/matrix-common/matrix-common-1.3.0-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Common code for Synapse, Sydent and Sygnal"
+HOMEPAGE="
+ https://github.com/matrix-org/matrix-python-common
+ https://pypi.org/project/matrix-common/
+"
+SRC_URI="
+ https://github.com/matrix-org/matrix-python-common/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+S="${WORKDIR}/matrix-python-common-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64"
+
+RDEPEND="
+ dev-python/attrs[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest