summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-10-02 18:15:15 +0200
committerMichał Górny <mgorny@gentoo.org>2022-10-02 18:15:43 +0200
commit8bbb4de02b334ad7b01629f315625dfcfdab462c (patch)
treee7f050cb3a628508596cf794787bc4ba20d8ce6d /dev-python/meson-python
parentsys-kernel/gentoo-kernel: Add a 5.19 config bump reminder (diff)
downloadgentoo-8bbb4de02b334ad7b01629f315625dfcfdab462c.tar.gz
gentoo-8bbb4de02b334ad7b01629f315625dfcfdab462c.tar.bz2
gentoo-8bbb4de02b334ad7b01629f315625dfcfdab462c.zip
dev-python/meson-python: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/meson-python')
-rw-r--r--dev-python/meson-python/Manifest2
-rw-r--r--dev-python/meson-python/files/meson-python-0.5.0-defaults.patch23
-rw-r--r--dev-python/meson-python/meson-python-0.8.0.ebuild45
-rw-r--r--dev-python/meson-python/meson-python-0.8.1.ebuild45
4 files changed, 0 insertions, 115 deletions
diff --git a/dev-python/meson-python/Manifest b/dev-python/meson-python/Manifest
index 7da26a4caace..0c76d3ad3b95 100644
--- a/dev-python/meson-python/Manifest
+++ b/dev-python/meson-python/Manifest
@@ -1,3 +1 @@
-DIST meson-python-0.8.0.gh.tar.gz 29367 BLAKE2B bf501ef73baa5481f5367b642cefca5a8b8655b4d74776aea21f0be4608c3e42d765f17ffdd037f39e7fc9c48d162293f93af61a30533e1823a66de5151ec1f9 SHA512 1709cdf3b357970566b25958cead88be2062e35ee8576275d0ca2571eca1f6a0211986b2693af0944026f2693511729b9d5cb30279952c65a287fa510c19186d
-DIST meson-python-0.8.1.gh.tar.gz 29353 BLAKE2B 13d6ab25da404301bddb2fb7eaaeb5af256efb5ce6d09581e4a8fa90d21c3a45cc8f455b09dc99b454e8457b55eb41261743c6ffd612c6c674ac9a28bcb98f51 SHA512 e46f6dbbcc2b5f89b17c7ea3f00e8ff9d68cad458bcbfe462e09de8e0074316c15f71fd88304ccf65cc42d98b193bcc0b3547be3ec2519e8c25d31556beb1468
DIST meson-python-0.9.0.gh.tar.gz 37253 BLAKE2B 29aa875dfc1c275ee4edab48bd2d46c783969fc0ab58f108be1a6443d5519028a2d36f666dc57c45d68ba77334cca2d11a0d4bfb8abb3822b537252c71b77286 SHA512 ae0927876533af65c5b1d8278ff6db3726f0551c160bfedcc602189fcad44c9412faa589738718aac2f10cf9497db8c632d89ccf1fb8519e6e7f4add78d8e52d
diff --git a/dev-python/meson-python/files/meson-python-0.5.0-defaults.patch b/dev-python/meson-python/files/meson-python-0.5.0-defaults.patch
deleted file mode 100644
index 07077ba4fdc2..000000000000
--- a/dev-python/meson-python/files/meson-python-0.5.0-defaults.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-See https://github.com/FFY00/meson-python/blob/main/mesonpy/__init__.py#L452.
-
-(Also: https://github.com/FFY00/meson-python/issues/54)
---- a/mesonpy/__init__.py
-+++ b/mesonpy/__init__.py
-@@ -452,7 +452,7 @@ class Project():
- f'--native-file={os.fspath(self._meson_native_file)}',
- # TODO: Allow configuring these arguments
- '-Ddebug=false',
-- '-Dstrip=true',
-+ '-Dstrip=false',
- '-Doptimization=2',
- *setup_args,
- )
-@@ -464,7 +464,7 @@ class Project():
-
- @functools.lru_cache(maxsize=None)
- def build(self) -> None:
-- self._meson('compile')
-+ self._meson('compile', '--verbose')
- self._meson('install', '--destdir', os.fspath(self._install_dir))
-
- @classmethod
diff --git a/dev-python/meson-python/meson-python-0.8.0.ebuild b/dev-python/meson-python/meson-python-0.8.0.ebuild
deleted file mode 100644
index 70f7d41728e8..000000000000
--- a/dev-python/meson-python/meson-python-0.8.0.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=standalone
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit distutils-r1
-
-DESCRIPTION="Meson PEP 517 Python build backend"
-HOMEPAGE="
- https://pypi.org/project/meson-python/
- https://github.com/FFY00/meson-python/
-"
-SRC_URI="
- https://github.com/FFY00/meson-python/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64"
-
-RDEPEND="
- >=dev-python/pyproject-metadata-0.5.0[${PYTHON_USEDEP}]
- >=dev-python/tomli-1.0.0[${PYTHON_USEDEP}]
- >=dev-util/meson-0.60.0[${PYTHON_USEDEP}]
- dev-util/patchelf
-"
-BDEPEND="
- test? (
- dev-python/GitPython[${PYTHON_USEDEP}]
- dev-python/pytest-mock[${PYTHON_USEDEP}]
- )
-"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-0.7.0-defaults.patch
-)
-
-distutils_enable_sphinx docs \
- dev-python/furo \
- dev-python/sphinx-autodoc-typehints
-distutils_enable_tests pytest
diff --git a/dev-python/meson-python/meson-python-0.8.1.ebuild b/dev-python/meson-python/meson-python-0.8.1.ebuild
deleted file mode 100644
index 0a2cc859b64c..000000000000
--- a/dev-python/meson-python/meson-python-0.8.1.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=standalone
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit distutils-r1
-
-DESCRIPTION="Meson PEP 517 Python build backend"
-HOMEPAGE="
- https://pypi.org/project/meson-python/
- https://github.com/FFY00/meson-python/
-"
-SRC_URI="
- https://github.com/FFY00/meson-python/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv"
-
-RDEPEND="
- >=dev-python/pyproject-metadata-0.5.0[${PYTHON_USEDEP}]
- >=dev-python/tomli-1.0.0[${PYTHON_USEDEP}]
- >=dev-util/meson-0.60.0[${PYTHON_USEDEP}]
- dev-util/patchelf
-"
-BDEPEND="
- test? (
- dev-python/GitPython[${PYTHON_USEDEP}]
- dev-python/pytest-mock[${PYTHON_USEDEP}]
- )
-"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-0.7.0-defaults.patch
-)
-
-distutils_enable_sphinx docs \
- dev-python/furo \
- dev-python/sphinx-autodoc-typehints
-distutils_enable_tests pytest