summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2023-10-05 20:10:44 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2023-10-05 20:10:44 +0300
commit68e0e2c5e8992ce587a8f89f9636b289a0e21967 (patch)
treed30b36150533a1fd54eea6b62946fb55eb49b21a /dev-python/mpmath
parentgui-libs/wlroots: install docs (diff)
downloadgentoo-68e0e2c5e8992ce587a8f89f9636b289a0e21967.tar.gz
gentoo-68e0e2c5e8992ce587a8f89f9636b289a0e21967.tar.bz2
gentoo-68e0e2c5e8992ce587a8f89f9636b289a0e21967.zip
dev-python/mpmath: enable py3.12, use optfeature
After verifying the code, the deps behind 2 USE flags are just optional runtime dependencies, so just use optfeature for it. Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/mpmath')
-rw-r--r--dev-python/mpmath/mpmath-1.3.0-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/mpmath/mpmath-1.3.0-r1.ebuild b/dev-python/mpmath/mpmath-1.3.0-r1.ebuild
new file mode 100644
index 000000000000..d6d7fdab14b5
--- /dev/null
+++ b/dev-python/mpmath/mpmath-1.3.0-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 optfeature pypi virtualx
+
+DESCRIPTION="Python library for arbitrary-precision floating-point arithmetic"
+HOMEPAGE="
+ https://mpmath.org/
+ https://github.com/mpmath/mpmath/
+ https://pypi.org/project/mpmath/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+
+distutils_enable_tests pytest
+
+src_test() {
+ virtx distutils-r1_src_test
+}
+
+python_test() {
+ "${EPYTHON}" mpmath/tests/runtests.py -local || die "Tests failed with ${EPYTHON}"
+}
+
+pkg_postinst() {
+ optfeature "gmp support" dev-python/gmpy
+ optfeature "matplotlib support" dev-python/matplotlib
+}