summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-03-03 06:06:37 +0100
committerMichał Górny <mgorny@gentoo.org>2023-03-03 06:53:09 +0100
commite21e5fcb688f80e25c8517bb01fd2d73d21ccbdd (patch)
treeac74cca2396d5c963e7c3924582f92391af5d6d7 /dev-python/myst-parser
parentdev-python/openapi-core: Bump to 0.16.6 (diff)
downloadgentoo-e21e5fcb688f80e25c8517bb01fd2d73d21ccbdd.tar.gz
gentoo-e21e5fcb688f80e25c8517bb01fd2d73d21ccbdd.tar.bz2
gentoo-e21e5fcb688f80e25c8517bb01fd2d73d21ccbdd.zip
dev-python/myst-parser: Bump to 0.19.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/myst-parser')
-rw-r--r--dev-python/myst-parser/Manifest1
-rw-r--r--dev-python/myst-parser/myst-parser-0.19.1.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/dev-python/myst-parser/Manifest b/dev-python/myst-parser/Manifest
index 1a6c205ba923..7fd007508ff0 100644
--- a/dev-python/myst-parser/Manifest
+++ b/dev-python/myst-parser/Manifest
@@ -1,2 +1,3 @@
DIST MyST-Parser-0.18.1.gh.tar.gz 769288 BLAKE2B 77f21ae4277ef4ed9020caad86ef3ea92a1efca35f7ab61203fe2125e4fab31a74a740db7a1f1d6ea0a576c24706b0997beea296d782eb5a07ba4e91a0a9e52d SHA512 4bc3a89480f175779da4f093aaa99a1516f76ab4107dcf8747b6614f347e91739f8596693f95529d76aedbb0c84b4efde4262517bc445aa7027d51e05e8b48bc
DIST MyST-Parser-0.19.0.gh.tar.gz 812180 BLAKE2B 44dd773dfcbd8c01b3089303e81b103ce3eba2432b1891b4fb35b8bbd9c0088b3245e6afe14c6378a262cdd4e7930da16ddc7ab6abb3a06779d4d0bd9e9ebd53 SHA512 3b646b78032914b42ab655d5f653f38fb58e4c51814fca0f987c8207f6fb97db6f3ba6b9951b3ecdf98430800b2a198cc2b26f17162b5b57309bfe74de3f4450
+DIST MyST-Parser-0.19.1.gh.tar.gz 812247 BLAKE2B 24a3502d2b9f81ec066c8fc5055b59448938fda63e74b47810e16cb2ce57b17fab1e219469df6e57fd1343453012855f104806e05e0831166af3506adc8589f5 SHA512 abe57048a9c19cfa08bb11c2ab988ebe462b4a104ffe3fc3b9083e2563da0bda271b5b1e278ac94e1d328bb70f5aeb20e72f81fc428fbb79dd6fb695abfd01cb
diff --git a/dev-python/myst-parser/myst-parser-0.19.1.ebuild b/dev-python/myst-parser/myst-parser-0.19.1.ebuild
new file mode 100644
index 000000000000..c578ea90b4a1
--- /dev/null
+++ b/dev-python/myst-parser/myst-parser-0.19.1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+
+inherit distutils-r1
+
+MY_P=MyST-Parser-${PV}
+DESCRIPTION="Extended commonmark compliant parser, with bridges to Sphinx"
+HOMEPAGE="
+ https://github.com/executablebooks/MyST-Parser/
+ https://pypi.org/project/myst-parser/
+"
+SRC_URI="
+ https://github.com/executablebooks/MyST-Parser/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ <dev-python/docutils-0.20[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/markdown-it-py[${PYTHON_USEDEP}]
+ >=dev-python/mdit-py-plugins-0.3.4[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ <dev-python/sphinx-7[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-5[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
+ dev-python/pytest-regressions[${PYTHON_USEDEP}]
+ dev-python/pytest-param-files[${PYTHON_USEDEP}]
+ dev-python/sphinx-pytest[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # Unimportant tests needing a new dep linkify
+ tests/test_renderers/test_myst_config.py::test_cmdline
+ tests/test_sphinx/test_sphinx_builds.py::test_extended_syntaxes
+ )
+
+ [[ ${EPYTHON} == pypy3 ]] && EPYTEST_DESELECT+=(
+ # bad test relying on exact exception messages
+ "tests/test_renderers/test_include_directive.py::test_errors[9-Non-existent path:]"
+ )
+
+ epytest
+}