summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sautier.louis@gmail.com>2016-03-12 22:04:57 +0100
committerPatrice Clement <monsieurp@gentoo.org>2016-03-12 21:35:27 +0000
commit2490b50c6e89e98fe462e506f9acb040244bf8fb (patch)
treefca7297ef47ab6107f330e6d277335819829c94f /dev-python/nagiosplugin/nagiosplugin-1.2.4.ebuild
parentapp-emulation/wine: Enable mono on 64 bit builds. Bug #577120 (diff)
downloadgentoo-2490b50c6e89e98fe462e506f9acb040244bf8fb.tar.gz
gentoo-2490b50c6e89e98fe462e506f9acb040244bf8fb.tar.bz2
gentoo-2490b50c6e89e98fe462e506f9acb040244bf8fb.zip
dev-python/nagiosplugin: bump to 1.2.4, EAPI=6
Package-Manager: portage-2.2.27 Closes: https://github.com/gentoo/gentoo/pull/1036
Diffstat (limited to 'dev-python/nagiosplugin/nagiosplugin-1.2.4.ebuild')
-rw-r--r--dev-python/nagiosplugin/nagiosplugin-1.2.4.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/nagiosplugin/nagiosplugin-1.2.4.ebuild b/dev-python/nagiosplugin/nagiosplugin-1.2.4.ebuild
new file mode 100644
index 000000000000..0345645b6fcc
--- /dev/null
+++ b/dev-python/nagiosplugin/nagiosplugin-1.2.4.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="A class library for writing nagios-compatible plugins"
+HOMEPAGE="https://bitbucket.org/flyingcircus/nagiosplugin/ https://pypi.python.org/pypi/nagiosplugin/"
+if [[ ${PV} == "9999" ]] ; then
+ inherit mercurial
+ EHG_REPO_URI="https://bitbucket.org/flyingcircus/nagiosplugin/"
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="ZPL"
+SLOT="0"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ esetup.py test
+}