summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-10-06 18:43:37 +0200
committerMichał Górny <mgorny@gentoo.org>2022-10-06 22:11:03 +0200
commit077e11c4ce701e04133b0de292c78db42ef76f7d (patch)
tree5a18c624f96fc4ba50c7baa5890e2ea310b29729 /dev-python/nbclient
parentapp-admin/awscli: Bump to 1.25.88 (diff)
downloadgentoo-077e11c4ce701e04133b0de292c78db42ef76f7d.tar.gz
gentoo-077e11c4ce701e04133b0de292c78db42ef76f7d.tar.bz2
gentoo-077e11c4ce701e04133b0de292c78db42ef76f7d.zip
dev-python/nbclient: Bump to 0.7.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/nbclient')
-rw-r--r--dev-python/nbclient/Manifest1
-rw-r--r--dev-python/nbclient/nbclient-0.7.0.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/nbclient/Manifest b/dev-python/nbclient/Manifest
index f0707f386f8f..7777ff3d0358 100644
--- a/dev-python/nbclient/Manifest
+++ b/dev-python/nbclient/Manifest
@@ -1,2 +1,3 @@
DIST nbclient-0.6.7.gh.tar.gz 78345 BLAKE2B dba9c98ab7d0b65470268dabc5d7dbee65e9c800252e61de6e9fe28a59a2da5c9b2046b7835468a8807445bb657152071cad7a28c717049d5762c13634175e34 SHA512 67fc7a6685df783a0d3af728e18ad2ff7a46d17c66a8e23f651a4d329896ee84d7dda8fcc62c94e277a742c74fe51b9f15f415add747a346ddf3d29056382f23
DIST nbclient-0.6.8.gh.tar.gz 78431 BLAKE2B a59490a42af5fb6090b7e4ddd8c469ddce015ca47ceca51290d9b3b2173d93d2a2d13839b227a78cdd72afdada1f305f810337dcc7aa08818afa78bbc96c4a1d SHA512 2393085e52e2e34574b6f60cff82317caf3b636f8476af20765282f0ebf158104fed3bb7fc8e8f800ff42f7eddc226cf7d9575c2043628fd926708ef71306c04
+DIST nbclient-0.7.0.gh.tar.gz 78253 BLAKE2B 473dcef140c8e1fc8f1e97fa30859b9b9fc2dfd6f951ae52db8ab11febbb3de7f60d129424827983a2c05579cd2340e9d4e1a9d0e452a7678497fc1c7176ecf3 SHA512 93d22e2b4fe1740798b812bb4890bf2fe2c7fdd337e34b50eac3140ead73d443cdb326948b2e8511b6ccad61c7daf1efd8e7cc3664b6b1ad9dda0894ca84fff5
diff --git a/dev-python/nbclient/nbclient-0.7.0.ebuild b/dev-python/nbclient/nbclient-0.7.0.ebuild
new file mode 100644
index 000000000000..343192040c27
--- /dev/null
+++ b/dev-python/nbclient/nbclient-0.7.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A client library for executing Jupyter notebooks"
+HOMEPAGE="
+ https://nbclient.readthedocs.io/en/latest/
+ https://github.com/jupyter/nbclient/
+ https://pypi.org/project/nbclient/
+"
+SRC_URI="
+ https://github.com/jupyter/nbclient/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/jupyter_client-6.1.5[${PYTHON_USEDEP}]
+ >=dev-python/nbformat-5.0[${PYTHON_USEDEP}]
+ dev-python/nest_asyncio[${PYTHON_USEDEP}]
+ >=dev-python/traitlets-5.2.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/ipython[${PYTHON_USEDEP}]
+ dev-python/ipykernel[${PYTHON_USEDEP}]
+ dev-python/ipywidgets[${PYTHON_USEDEP}]
+ dev-python/testpath[${PYTHON_USEDEP}]
+ dev-python/xmltodict[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ nbclient/tests/test_client.py::test_many_parallel_notebooks
+ 'nbclient/tests/test_client.py::test_run_all_notebooks[Interrupt.ipynb-opts6]'
+)