summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2016-09-29 16:42:45 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2016-09-29 22:43:40 -0500
commit19adfded88fa698aa49dd5310b231e9cb57a3ff5 (patch)
tree1f7c14336a06f1350c52b08df7a9d1c9e3cbf612 /dev-python/oslo-policy
parentsci-libs/blas-reference: ebuild maintenance, cleanup (diff)
downloadgentoo-19adfded88fa698aa49dd5310b231e9cb57a3ff5.tar.gz
gentoo-19adfded88fa698aa49dd5310b231e9cb57a3ff5.tar.bz2
gentoo-19adfded88fa698aa49dd5310b231e9cb57a3ff5.zip
add initial support for newton (keystone)
dropped py3.3 and updated most (maybe all) to eapi6
Diffstat (limited to 'dev-python/oslo-policy')
-rw-r--r--dev-python/oslo-policy/Manifest1
-rw-r--r--dev-python/oslo-policy/oslo-policy-1.14.0.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/oslo-policy/Manifest b/dev-python/oslo-policy/Manifest
index d900f0070313..7c579fe73916 100644
--- a/dev-python/oslo-policy/Manifest
+++ b/dev-python/oslo-policy/Manifest
@@ -1 +1,2 @@
+DIST oslo.policy-1.14.0.tar.gz 58516 SHA256 cedbc22f191524ae2a98e42e53fe7e4adcd5e0715b4c176b9daaa9dcb85cbab9 SHA512 3cf6e3f77a82761106b0ec73570faadc5f493fbb7f139e9bd2c3114ad773d785f5d5a8d3218b624259558e73cc8122e110c685a60205cb7ef1d8580412a851c0 WHIRLPOOL 1b3eece66117f14390e8b4efee9414ec4cd715c6913a7d69b5662531f7be898aab0b60cb55cb399b0c0b2478b4751415a5bede22a21bb465606a9d88ab3c1776
DIST oslo.policy-1.6.0.tar.gz 38076 SHA256 24d5ecdf4e10f33a9fb2e8784876f73276637d8663c33f594e8efc99e179016a SHA512 468fcad020c90ce55b8f12199952f946cef6f352f3abc72b64e4538a6bd98dbf1d7ebe191600cff0e2654f97e4af3ccfc480a88c36133f33045ce37c2692a31c WHIRLPOOL b84ebb32db93710c5019dda8833129f3ccc855486655daf7b937eb3ad786b501cd51a9fdb4b55819dd414cdb3151a72b2d7ffd118c015bc1ca7b68a60c5a435d
diff --git a/dev-python/oslo-policy/oslo-policy-1.14.0.ebuild b/dev-python/oslo-policy/oslo-policy-1.14.0.ebuild
new file mode 100644
index 000000000000..eff7fe122ba2
--- /dev/null
+++ b/dev-python/oslo-policy/oslo-policy-1.14.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_4 python3_5)
+
+inherit distutils-r1
+
+DESCRIPTION="Provides support for RBAC policy enforcement across all OpenStack services."
+HOMEPAGE="https://pypi.python.org/pypi/oslo.policy"
+SRC_URI="mirror://pypi/${PN:0:1}/oslo.policy/oslo.policy-${PV}.tar.gz"
+S="${WORKDIR}/oslo.policy-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="test"
+
+CDEPEND=">=dev-python/pbr-1.8[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}
+ test? (
+ >=dev-python/oslotest-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-mock-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-sphinx-2.5.0[${PYTHON_USEDEP}]
+ !~dev-python/oslo-sphinx-3.4.0[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}]
+ !~dev-python/sphinx-1.2.0[${PYTHON_USEDEP}]
+ <dev-python/sphinx-1.3.0[${PYTHON_USEDEP}]
+ >=dev-python/reno-1.8.0[${PYTHON_USEDEP}]
+ )"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/requests-2.10.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-config-3.14.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-serialization-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.16.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+"
+
+# This time half the doc files are missing; Do you want them?
+
+python_prepare_all() {
+ sed -i '/^hacking/d' test-requirements.txt || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ nosetests tests/ || die "test failed under ${EPYTHON}"
+}