summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2019-04-16 00:38:21 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2019-04-16 00:40:23 -0500
commitd6e7db2e3adfb20a6d2104857f8e9cbacd270068 (patch)
treec6a3f3a23432fa8eb926a040075fa37a199521a5 /dev-python/ovs/ovs-2.10.0-r1.ebuild
parentdev-ruby/shoulda: add ruby26 (diff)
downloadgentoo-d6e7db2e3adfb20a6d2104857f8e9cbacd270068.tar.gz
gentoo-d6e7db2e3adfb20a6d2104857f8e9cbacd270068.tar.bz2
gentoo-d6e7db2e3adfb20a6d2104857f8e9cbacd270068.zip
dev-python/ovs: add missing dep
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-python/ovs/ovs-2.10.0-r1.ebuild')
-rw-r--r--dev-python/ovs/ovs-2.10.0-r1.ebuild19
1 files changed, 19 insertions, 0 deletions
diff --git a/dev-python/ovs/ovs-2.10.0-r1.ebuild b/dev-python/ovs/ovs-2.10.0-r1.ebuild
new file mode 100644
index 000000000000..bde0c8557767
--- /dev/null
+++ b/dev-python/ovs/ovs-2.10.0-r1.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="OVS bindings for python."
+HOMEPAGE="https://github.com/openvswitch/ovs/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="dev-python/sortedcontainers[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"