summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-03-31 14:41:42 +0200
committerMichał Górny <mgorny@gentoo.org>2022-03-31 14:42:19 +0200
commita462de4fc67bcb57725672d1f1d7534d3fcdaf0d (patch)
tree94bf32b152f86d5c4980f1b49b503feb8ec4683b /dev-python/path-py/path-py-16.2.0.ebuild
parentdev-python/phonenumbers: Remove old (diff)
downloadgentoo-a462de4fc67bcb57725672d1f1d7534d3fcdaf0d.tar.gz
gentoo-a462de4fc67bcb57725672d1f1d7534d3fcdaf0d.tar.bz2
gentoo-a462de4fc67bcb57725672d1f1d7534d3fcdaf0d.zip
dev-python/path-py: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/path-py/path-py-16.2.0.ebuild')
-rw-r--r--dev-python/path-py/path-py-16.2.0.ebuild38
1 files changed, 0 insertions, 38 deletions
diff --git a/dev-python/path-py/path-py-16.2.0.ebuild b/dev-python/path-py/path-py-16.2.0.ebuild
deleted file mode 100644
index 161aeaf60c7a..000000000000
--- a/dev-python/path-py/path-py-16.2.0.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
-inherit distutils-r1
-
-MY_P="path-${PV}"
-DESCRIPTION="A module wrapper for os.path"
-HOMEPAGE="https://pypi.org/project/path/ https://github.com/jaraco/path"
-SRC_URI="mirror://pypi/p/path/${MY_P}.tar.gz"
-S=${WORKDIR}/${MY_P}
-
-SLOT="0"
-LICENSE="MIT"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~x64-macos"
-
-RDEPEND="
- dev-python/appdirs[${PYTHON_USEDEP}]
- !<dev-python/pytest-shutil-1.7.0-r1
- !<dev-python/pytest-virtualenv-1.7.0-r1"
-BDEPEND="
- dev-python/setuptools_scm[${PYTHON_USEDEP}]
- test? (
- dev-python/packaging[${PYTHON_USEDEP}]
- )"
-
-distutils_enable_tests pytest
-
-python_test() {
- local deselect=(
- # unreliable, not really meaningful for end users
- test_path.py::TestPerformance
- )
-
- epytest ${deselect[@]/#/--deselect }
-}