summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-12-14 14:47:02 +0100
committerMichał Górny <mgorny@gentoo.org>2024-12-14 14:47:41 +0100
commit35029d5ef189ced0d0cc7bff0a1e90e82c7abf0c (patch)
tree30fdc4c94d502c113e2534c540877de792aa1342 /dev-python/pdoc3/files
parentdev-python/trimesh: Remove old (diff)
downloadgentoo-35029d5ef189ced0d0cc7bff0a1e90e82c7abf0c.tar.gz
gentoo-35029d5ef189ced0d0cc7bff0a1e90e82c7abf0c.tar.bz2
gentoo-35029d5ef189ced0d0cc7bff0a1e90e82c7abf0c.zip
dev-python/pdoc3: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pdoc3/files')
-rw-r--r--dev-python/pdoc3/files/pdoc3-0.10.0-update-tests.patch114
-rw-r--r--dev-python/pdoc3/files/pdoc3-TST-use-explicit-ClassWithNew-instead-of-typing.Gene.patch43
2 files changed, 0 insertions, 157 deletions
diff --git a/dev-python/pdoc3/files/pdoc3-0.10.0-update-tests.patch b/dev-python/pdoc3/files/pdoc3-0.10.0-update-tests.patch
deleted file mode 100644
index bd68ea2d8368..000000000000
--- a/dev-python/pdoc3/files/pdoc3-0.10.0-update-tests.patch
+++ /dev/null
@@ -1,114 +0,0 @@
-From 80af5d40d3ca39e2701c44941c1003ae6a280799 Mon Sep 17 00:00:00 2001
-From: Kernc <kerncece@gmail.com>
-Date: Sat, 29 Oct 2022 18:55:46 +0200
-Subject: [PATCH] CI: Bump min Python 3.7+ and update tests for Python 3.10
-
-Fix https://github.com/pdoc3/pdoc/issues/400
-Thanks @tjni
---- a/pdoc/__init__.py
-+++ b/pdoc/__init__.py
-@@ -1275,7 +1275,7 @@ def _formatannotation(annot):
- `typing.Optional`, `nptyping.NDArray` and other types.
-
- >>> _formatannotation(NewType('MyType', str))
-- 'MyType'
-+ 'pdoc.MyType'
- >>> _formatannotation(Optional[Tuple[Optional[int], None]])
- 'Optional[Tuple[Optional[int], None]]'
- """
---- a/pdoc/documentation.md
-+++ b/pdoc/documentation.md
-@@ -353,7 +353,7 @@ modified templates into the `directories` list of the
-
- Compatibility
- -------------
--`pdoc` requires Python 3.6+.
-+`pdoc` requires Python 3.7+.
- The last version to support Python 2.x is [pdoc3 0.3.x].
-
- [pdoc3 0.3.x]: https://pypi.org/project/pdoc3/0.3.13/
---- a/pdoc/test/__init__.py
-+++ b/pdoc/test/__init__.py
-@@ -126,7 +126,8 @@ class CliTest(unittest.TestCase):
- def setUp(self):
- pdoc.reset()
-
-- @unittest.skipIf(sys.version_info < (3, 7), 'pdoc._formatannotation fails on Py3.6')
-+ @unittest.skipIf(sys.version_info < (3, 10),
-+ 'HACK: _formatannotation() changed return value in Py3.10')
- def test_project_doctests(self):
- doctests = doctest.testmod(pdoc)
- assert not doctests.failed and doctests.attempted, doctests
-@@ -185,8 +186,12 @@ def test_html(self):
- '<object ',
- ' class="ident">_private',
- ' class="ident">_Private',
-- 'non_callable_routine',
- ]
-+ if sys.version_info >= (3, 10):
-+ include_patterns.append('non_callable_routine')
-+ else:
-+ exclude_patterns.append('non_callable_routine')
-+
- package_files = {
- '': self.PUBLIC_FILES,
- '.subpkg2': [f for f in self.PUBLIC_FILES
-@@ -356,8 +361,11 @@ def test_text(self):
- '_Private',
- 'subprocess',
- 'Hidden',
-- 'non_callable_routine',
- ]
-+ if sys.version_info >= (3, 10):
-+ include_patterns.append('non_callable_routine')
-+ else:
-+ exclude_patterns.append('non_callable_routine')
-
- with self.subTest(package=EXAMPLE_MODULE):
- with redirect_streams() as (stdout, _):
-@@ -543,8 +551,9 @@ class C:
- self.assertEqual(doc.doc['vars_dont'].docstring, '')
- self.assertIn('integer', doc.doc['but_clss_have_doc'].docstring)
-
-+ @unittest.skipIf(sys.version_info >= (3, 10), 'No builtin module "parser" in Py3.10')
- def test_builtin_methoddescriptors(self):
-- import parser
-+ import parser # TODO: replace with another public binary builtin
- with self.assertWarns(UserWarning):
- c = pdoc.Class('STType', pdoc.Module(parser), parser.STType)
- self.assertIsInstance(c.doc['compile'], pdoc.Function)
-@@ -906,9 +915,13 @@ def bug130_str_annotation(a: "str"):
- def bug253_newtype_annotation(a: CustomType):
- return
-
-+ expected = CustomType.__name__
-+ if sys.version_info > (3, 10):
-+ expected = f'{__name__}.{CustomType.__name__}'
-+
- self.assertEqual(
- pdoc.Function('bug253', mod, bug253_newtype_annotation).params(annotate=True),
-- ['a:\N{NBSP}CustomType'])
-+ [f'a:\N{NBSP}{expected}'])
-
- # typing.Callable bug
- def f(a: typing.Callable):
---- a/setup.py
-+++ b/setup.py
-@@ -2,8 +2,8 @@
- import sys
- from setuptools import setup, find_packages
-
--if sys.version_info < (3, 6):
-- sys.exit('ERROR: pdoc requires Python 3.6+')
-+if sys.version_info < (3, 7):
-+ sys.exit('ERROR: pdoc requires Python 3.7+')
-
-
- def _discover_tests():
-@@ -58,5 +58,5 @@ def _discover_tests():
- 'write_to': os.path.join('pdoc', '_version.py'),
- },
- test_suite="setup._discover_tests",
-- python_requires='>= 3.6',
-+ python_requires='>= 3.7',
- )
diff --git a/dev-python/pdoc3/files/pdoc3-TST-use-explicit-ClassWithNew-instead-of-typing.Gene.patch b/dev-python/pdoc3/files/pdoc3-TST-use-explicit-ClassWithNew-instead-of-typing.Gene.patch
deleted file mode 100644
index b969bf4727bc..000000000000
--- a/dev-python/pdoc3/files/pdoc3-TST-use-explicit-ClassWithNew-instead-of-typing.Gene.patch
+++ /dev/null
@@ -1,43 +0,0 @@
-From 4aa70de2221a34a3003a7e5f52a9b91965f0e359 Mon Sep 17 00:00:00 2001
-From: Spencer Baugh <sbaugh@catern.com>
-Date: Thu, 23 Sep 2021 09:00:25 -0400
-Subject: [PATCH] TST: use explicit ClassWithNew instead of typing.Generic
-
-typing.Generic doesn't have a __new__ method in 3.9.
-
-Fixes https://github.com/pdoc3/pdoc/issues/355
----
- pdoc/test/__init__.py | 10 +++++++---
- 1 file changed, 7 insertions(+), 3 deletions(-)
-
-diff --git a/pdoc/test/__init__.py b/pdoc/test/__init__.py
-index e8c3d94a805b..8b67ab77d3f7 100644
---- a/pdoc/test/__init__.py
-+++ b/pdoc/test/__init__.py
-@@ -1043,16 +1043,20 @@ class Foo:
-
- self.assertEqual(pdoc.Class('C2', mod, C2).params(), ['a', 'b', 'c=None', '*', 'd=1', 'e'])
-
-- class G(typing.Generic[T]):
-+ class ClassWithNew:
-+ def __new__(self, arg):
-+ pass
-+
-+ class G(ClassWithNew):
- def __init__(self, a, b, c=100):
- pass
-
- self.assertEqual(pdoc.Class('G', mod, G).params(), ['a', 'b', 'c=100'])
-
-- class G2(typing.Generic[T]):
-+ class G2(ClassWithNew):
- pass
-
-- self.assertEqual(pdoc.Class('G2', mod, G2).params(), ['*args', '**kwds'])
-+ self.assertEqual(pdoc.Class('G2', mod, G2).params(), ['arg'])
-
- def test_url(self):
- mod = pdoc.Module(EXAMPLE_MODULE)
---
-2.32.0
-