summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-05-03 07:13:14 +0200
committerMichał Górny <mgorny@gentoo.org>2023-05-03 07:13:14 +0200
commit568e226f23ee69a22bbd06b1e2453a674b0706ae (patch)
treebc3f88baaeb65a35fee515f82051fad187acbe23 /dev-python/picobox
parentdev-python/pytest-jupyter: Remove old (diff)
downloadgentoo-568e226f23ee69a22bbd06b1e2453a674b0706ae.tar.gz
gentoo-568e226f23ee69a22bbd06b1e2453a674b0706ae.tar.bz2
gentoo-568e226f23ee69a22bbd06b1e2453a674b0706ae.zip
dev-python/picobox: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/picobox')
-rw-r--r--dev-python/picobox/Manifest1
-rw-r--r--dev-python/picobox/files/picobox-2.2.0-fix-py3.10.patch26
-rw-r--r--dev-python/picobox/picobox-2.2.0.ebuild29
3 files changed, 0 insertions, 56 deletions
diff --git a/dev-python/picobox/Manifest b/dev-python/picobox/Manifest
index 6fca50562b08..8a65ac80232b 100644
--- a/dev-python/picobox/Manifest
+++ b/dev-python/picobox/Manifest
@@ -1,2 +1 @@
-DIST picobox-2.2.0.tar.gz 30231 BLAKE2B 9911e2e41a850b57d4a642aa454e55703e0546bdb3a5b95aa4a15747388413babaec7dc3a3f7fcb7ecae7ecd0f81dc203161975ca393f87353987825e0413355 SHA512 d127ea71637105285701ae5252e59e0c940077fbbe044ba1f42f80134ea08291344ebb6bc8bce240112a7efe0be8561c8040b43d20912f1fbd121098578a1795
DIST picobox-3.0.0.tar.gz 28599 BLAKE2B e29dd7b0b5b23175a21f8fe6efe83adc6edfb0302c7a27f92f518deeba8f74f8e2d481a8eef6a1363fa0fb02ffc00b462181bab09872f6da5c1c9063c4d274e6 SHA512 ac8cecba10527e7dc096eb66f3b6743b523c305bd9725d5be8ec2822857a65ef8e9cc0ddcb85b8c656c557e7dc6cf0903035753bf8fe8cc2616b463e0a82bb5d
diff --git a/dev-python/picobox/files/picobox-2.2.0-fix-py3.10.patch b/dev-python/picobox/files/picobox-2.2.0-fix-py3.10.patch
deleted file mode 100644
index 74c6f9b2193f..000000000000
--- a/dev-python/picobox/files/picobox-2.2.0-fix-py3.10.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-diff --git a/tests/test_box.py b/tests/test_box.py
-index c1c1ca2..d576086 100644
---- a/tests/test_box.py
-+++ b/tests/test_box.py
-@@ -402,7 +402,7 @@ def test_box_pass_unexpected_argument(boxclass):
- with pytest.raises(TypeError) as excinfo:
- fn(1, 2)
-
-- assert str(excinfo.value) == "fn() got an unexpected keyword argument 'd'"
-+ assert "fn() got an unexpected keyword argument 'd'" in str(excinfo.value)
-
-
- def test_box_pass_keyerror(boxclass):
-diff --git a/tests/test_stack.py b/tests/test_stack.py
-index 725d378..10129b3 100644
---- a/tests/test_stack.py
-+++ b/tests/test_stack.py
-@@ -472,7 +472,7 @@ def test_box_pass_unexpected_argument(boxclass, teststack):
- with pytest.raises(TypeError) as excinfo:
- fn(1, 2)
-
-- assert str(excinfo.value) == "fn() got an unexpected keyword argument 'd'"
-+ assert "fn() got an unexpected keyword argument 'd'" in str(excinfo.value)
-
-
- def test_box_pass_keyerror(boxclass, teststack):
diff --git a/dev-python/picobox/picobox-2.2.0.ebuild b/dev-python/picobox/picobox-2.2.0.ebuild
deleted file mode 100644
index 21e6a6424b63..000000000000
--- a/dev-python/picobox/picobox-2.2.0.ebuild
+++ /dev/null
@@ -1,29 +0,0 @@
-# Copyright 2022-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{9..10} )
-DISTUTILS_USE_PEP517=setuptools
-inherit distutils-r1 pypi
-
-DESCRIPTION="Dependency injection framework designed with Python in mind"
-HOMEPAGE="https://pypi.org/project/picobox/
- https://github.com/ikalnytskyi/picobox"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 hppa ~ia64 ppc ppc64 ~riscv ~s390 sparc x86"
-
-BDEPEND="
- dev-python/setuptools-scm[${PYTHON_USEDEP}]
- test? (
- dev-python/flask[${PYTHON_USEDEP}]
- )
-"
-
-PATCHES=(
- "${FILESDIR}/${P}-fix-py3.10.patch"
-)
-
-distutils_enable_tests pytest