summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-11-01 08:47:52 +0100
committerMichał Górny <mgorny@gentoo.org>2021-11-01 09:32:10 +0100
commit95b9b811fbdbfdddb7f89b2828516a55c9152a32 (patch)
tree311ccdfe283efd7a379b0936befc1452afb79f6d /dev-python/pikepdf
parentdev-python/moto: Bump to 2.2.12 (diff)
downloadgentoo-95b9b811fbdbfdddb7f89b2828516a55c9152a32.tar.gz
gentoo-95b9b811fbdbfdddb7f89b2828516a55c9152a32.tar.bz2
gentoo-95b9b811fbdbfdddb7f89b2828516a55c9152a32.zip
dev-python/pikepdf: Bump to 4.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pikepdf')
-rw-r--r--dev-python/pikepdf/Manifest1
-rw-r--r--dev-python/pikepdf/pikepdf-4.0.0.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/pikepdf/Manifest b/dev-python/pikepdf/Manifest
index 413cd5cd27c4..b957829e5e0f 100644
--- a/dev-python/pikepdf/Manifest
+++ b/dev-python/pikepdf/Manifest
@@ -1 +1,2 @@
DIST pikepdf-3.2.0.tar.gz 2335339 BLAKE2B 3d294c2c8241bfcfa2b84f4c6af10e4da2e624374af0aed9c4fa597f9d0a789b9d85cb074d945ba521dbdd10f126326bb6d698a97102a93e6de589d89d7fee57 SHA512 307e2289811697b65c021e90496a4d1606e171e557bf5f19e5327be782e59e8683847524eb177ced54612d1e586b070860119a51e74fe25003787b359bf74531
+DIST pikepdf-4.0.0.tar.gz 2335830 BLAKE2B 80e36162709cd9eb23ce70994286d51cd4e83d242dafe65c724fa64a46b67bee048d76efa3934717334ba196d98d7ec70dd7f20b5d42a2a2d56326603f0adc88 SHA512 5727f60c05a72d1b7a249803020358cbb579e180ad1e5685d6120443b75a2b8483bd16c5c705f1fccd5159a0ab23a8b844ab57d39499ce4bf883e5caf2710051
diff --git a/dev-python/pikepdf/pikepdf-4.0.0.ebuild b/dev-python/pikepdf/pikepdf-4.0.0.ebuild
new file mode 100644
index 000000000000..80dd3fd26a41
--- /dev/null
+++ b/dev-python/pikepdf/pikepdf-4.0.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+MY_P=${P/_p/.post}
+DESCRIPTION="Python library to work with pdf files based on qpdf"
+HOMEPAGE="https://pypi.org/project/pikepdf/ https://github.com/pikepdf/pikepdf"
+SRC_URI="
+ https://github.com/${PN}/${PN}/archive/v${PV/_p/.post}.tar.gz
+ -> ${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND=">=app-text/qpdf-10.3.1:0="
+RDEPEND="${DEPEND}
+ >=dev-python/pillow-7[${PYTHON_USEDEP}]
+ >=dev-python/lxml-4.0[${PYTHON_USEDEP}]
+ >=dev-python/pybind11-2.7.1[${PYTHON_USEDEP}]"
+BDEPEND="
+ >=dev-python/pybind11-2.7.1[${PYTHON_USEDEP}]
+ >=dev-python/setuptools_scm-4.1[${PYTHON_USEDEP}]
+ dev-python/toml[${PYTHON_USEDEP}]
+ dev-python/setuptools_scm_git_archive[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/attrs-20.2.0[${PYTHON_USEDEP}]
+ >=dev-python/hypothesis-5[${PYTHON_USEDEP}]
+ >=dev-python/pillow-5.0.0[${PYTHON_USEDEP},jpeg,lcms,tiff]
+ >=dev-python/psutil-5[${PYTHON_USEDEP}]
+ >=dev-python/pytest-6[${PYTHON_USEDEP}]
+ >=dev-python/pytest-timeout-1.4.2[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.8.0[${PYTHON_USEDEP}]
+ >=dev-python/python-xmp-toolkit-2.0.1[${PYTHON_USEDEP}]
+ )"
+
+#distutils_enable_sphinx docs \
+# dev-python/ipython \
+# dev-python/matplotlib \
+# dev-python/sphinx_rtd_theme
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -i -e '/-n auto/d' pyproject.toml || die
+ distutils-r1_src_prepare
+}