summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-02-18 07:29:43 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-18 08:03:02 +0100
commitc78b67b2df253f1e343f0add5ef9ba5703b1f531 (patch)
tree0f3ac99def0d48ea97a30cb1efb5bb0690bf529c /dev-python/pip
parentdev-python/ensurepip-wheel: New package, v0.38.4, for pip tests (diff)
downloadgentoo-c78b67b2df253f1e343f0add5ef9ba5703b1f531.tar.gz
gentoo-c78b67b2df253f1e343f0add5ef9ba5703b1f531.tar.bz2
gentoo-c78b67b2df253f1e343f0add5ef9ba5703b1f531.zip
dev-python/pip: Use wheel from dev-python/ensurepip-wheel
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pip')
-rw-r--r--dev-python/pip/Manifest1
-rw-r--r--dev-python/pip/pip-23.0.1.ebuild12
2 files changed, 5 insertions, 8 deletions
diff --git a/dev-python/pip/Manifest b/dev-python/pip/Manifest
index db74b94b3188..756e2fa93fbe 100644
--- a/dev-python/pip/Manifest
+++ b/dev-python/pip/Manifest
@@ -4,4 +4,3 @@ DIST pip-23.0.gh.tar.gz 9336486 BLAKE2B 693623292e498ec939ce931063bccc8079fc313a
DIST setuptools-62.3.2-py3-none-any.whl 1225929 BLAKE2B 608952e201f749ebf557e3962ba9856d5bdcbc534f3a25598cab0d6c53282cfb3b9f007ba135497a8addf49db4c02bc4387c486d95a4529d01ce4114154ec28a SHA512 366d69dc44e326dd7549cdacd8dec481a14dce4feef4338adc38b9de5c4c338f04d61696e13ce8603be1315f2e8734100f92d3fe4b4b11843e19f550c9631978
DIST virtualenv-16.7.12.gh.tar.gz 8906590 BLAKE2B a1f206769e4e5797562906162e492e44c4a72720e4f88a0362dc802ce2df20c65aaab6a72dce2238445601a10fae59bd90cd362217994d30911f105afd71c5fa SHA512 0278b33fb19f6553e70ad3dcffa6ea1a455ff435b216ac9b4fadff216b2932714faa2bb6027af3058010111d8511a5c2fcd424f31c9645be361603971f111c8e
DIST wheel-0.36.2-py2.py3-none-any.whl 35046 BLAKE2B bc4e8dab7c74eea34d3b4a813b7eaf6295a99a396a861b6cdd76f743043e89140bad132bdd13e385e8945ce02e0798e1d3ac73fc1b23bde5b2a83e4bb4dd5cdc SHA512 6bb5119b4d3704fe1e3c1eaaa3124edab13f61b46f8a0a8e75974fac4e5b25d8b53606071a03a8d8990ad1cfe2ab247ddea260098df2c0c35ae965be47080284
-DIST wheel-0.38.4-py3-none-any.whl 36051 BLAKE2B 6c7d26fef5c6ec7987066d37579dd46a6b7704c4ec48c9f891cefdde5adf3a76934db9a912e6a05cc9d876782b7649110b814fd0df2e1af569f0336e47b3f850 SHA512 4d39de03dd3e87758de896c41240d58ed718e67042f33b0173446655e7c9d2c7d44f12e7a840058c93b9471c1492868ce38ef912d38e1bea723d082b329a4e4a
diff --git a/dev-python/pip/pip-23.0.1.ebuild b/dev-python/pip/pip-23.0.1.ebuild
index c0af4de71b0e..a27c9b63b397 100644
--- a/dev-python/pip/pip-23.0.1.ebuild
+++ b/dev-python/pip/pip-23.0.1.ebuild
@@ -12,9 +12,6 @@ PYTHON_REQ_USE="ssl(+),threads(+)"
inherit bash-completion-r1 distutils-r1 multiprocessing
-# setuptools & wheel .whl files are required for testing,
-# the exact version is not very important.
-WHEEL_WHL="wheel-0.38.4-py3-none-any.whl"
# upstream still requires virtualenv-16 for testing, we are now fetching
# it directly to avoid blockers with virtualenv-20
VENV_PV=16.7.12
@@ -28,7 +25,6 @@ HOMEPAGE="
SRC_URI="
https://github.com/pypa/${PN}/archive/${PV}.tar.gz -> ${P}.gh.tar.gz
test? (
- https://files.pythonhosted.org/packages/py3/w/wheel/${WHEEL_WHL}
https://github.com/pypa/virtualenv/archive/${VENV_PV}.tar.gz
-> virtualenv-${VENV_PV}.gh.tar.gz
)
@@ -49,6 +45,7 @@ BDEPEND="
test? (
$(python_gen_cond_dep '
dev-python/ensurepip-setuptools
+ dev-python/ensurepip-wheel
dev-python/freezegun[${PYTHON_USEDEP}]
dev-python/pretend[${PYTHON_USEDEP}]
dev-python/pytest-xdist[${PYTHON_USEDEP}]
@@ -73,10 +70,11 @@ python_prepare_all() {
distutils-r1_python_prepare_all
if use test; then
- local setuptools_whl=( "${BROOT}"/usr/lib/python/ensurepip/setuptools-*.whl )
+ local wheels=(
+ "${BROOT}"/usr/lib/python/ensurepip/{setuptools,wheel}-*.whl
+ )
mkdir tests/data/common_wheels/ || die
- cp "${setuptools_whl[@]}" "${DISTDIR}"/${WHEEL_WHL} \
- tests/data/common_wheels/ || die
+ cp "${wheels[@]}" tests/data/common_wheels/ || die
fi
}