summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-05-16 17:07:49 +0200
committerMichał Górny <mgorny@gentoo.org>2024-05-16 17:28:27 +0200
commit0473920eb08c254735eb442c4e42207637a516b0 (patch)
treedd8d6179ce3dac2261677ed2d76b1eeb17f0ae92 /dev-python/platformdirs
parentdev-python/genson: Bump to 1.3.0 (diff)
downloadgentoo-0473920eb08c254735eb442c4e42207637a516b0.tar.gz
gentoo-0473920eb08c254735eb442c4e42207637a516b0.tar.bz2
gentoo-0473920eb08c254735eb442c4e42207637a516b0.zip
dev-python/platformdirs: Bump to 4.2.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/platformdirs')
-rw-r--r--dev-python/platformdirs/Manifest1
-rw-r--r--dev-python/platformdirs/platformdirs-4.2.2.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/dev-python/platformdirs/Manifest b/dev-python/platformdirs/Manifest
index 003455160061..b079208f7ccf 100644
--- a/dev-python/platformdirs/Manifest
+++ b/dev-python/platformdirs/Manifest
@@ -1,2 +1,3 @@
DIST platformdirs-4.2.0.tar.gz 20055 BLAKE2B 07338fc1ad6f5edf3dfe9de9e74326af4c22a4b6db0979a2b0926d248e7bc27f6f40e9e47e62979657c0804e3d296dfba5b18f57fa64b1fdcd205d52ae21fe17 SHA512 615742163cc4eb0ee97c4dba069d59a08e0056e05a3fbeab32dcab854ed56976e8707dd70afd65dbd0732bf1ad1a42c565fb3d980b7b668aa2cdecc5cc1de4f0
DIST platformdirs-4.2.1.tar.gz 20398 BLAKE2B 6ae25a07afb0878a3c5347f4cc48e81117a5be42affe6b7873e1e62d9b4e8e63f380eb2a4062a472823c1d3e1eaaf499463ec93ca7e3c7c115c51a1c8fb10284 SHA512 c6c671022a74ba35610469f08e9a275daa19f0362a98208096fab147a77abfc96c12a0312fdf65668b3e457e0c06d938f141efec1217ef1a7598a77f65786130
+DIST platformdirs-4.2.2.tar.gz 20916 BLAKE2B d7c551a950118a127664b8210f33497760ce06381ac6a4ea098d1a1c60605507b5e2a9762d5f7d112332d3cebd63cb642b25e93a8b67dd2a1ee7cca189f3555f SHA512 e67aff332a6c84669d77a68e7d5546bfd14e08dcf61681b03447bf6381c0d981c63be0f87fd63bc99f0a51c92bf960902ded83ba8872801c14755ab163d45a0f
diff --git a/dev-python/platformdirs/platformdirs-4.2.2.ebuild b/dev-python/platformdirs/platformdirs-4.2.2.ebuild
new file mode 100644
index 000000000000..8bc5289f889b
--- /dev/null
+++ b/dev-python/platformdirs/platformdirs-4.2.2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A small Python module for determining appropriate platform-specific dirs"
+HOMEPAGE="
+ https://pypi.org/project/platformdirs/
+ https://github.com/platformdirs/platformdirs/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~arm64-macos ~x64-macos ~x64-solaris"
+
+BDEPEND="
+ test? (
+ dev-python/appdirs[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_configure() {
+ grep -q 'build-backend = "hatchling' pyproject.toml ||
+ die "Upstream changed build-backend, recheck"
+ # write a custom pyproject.toml to ease setuptools bootstrap
+ cat > pyproject.toml <<-EOF || die
+ [build-system]
+ requires = ["flit_core >=3.2,<4"]
+ build-backend = "flit_core.buildapi"
+
+ [project]
+ name = "${PN}"
+ version = "${PV}"
+ description = 'A small Python package for determining appropriate platform-specific dirs, e.g. a "user data dir".'
+ EOF
+ # sigh
+ cat > src/platformdirs/version.py <<-EOF || die
+ __version__ = version = '${PV}'
+ __version_tuple__ = version_tuple = (${PV//./, })
+ EOF
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p pytest_mock
+}