summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2018-03-09 11:59:36 -0800
committerTim Harder <radhermit@gentoo.org>2018-03-10 18:05:55 -0800
commitf0c867ddc8ce438e8da68b200b69ffb372f0ade1 (patch)
tree47855f3facbd9092acff4f4bb4a630e64b297af0 /dev-python/polib/polib-1.1.0.ebuild
parentprofiles/arch/hppa: Mask USE=iscsi (diff)
downloadgentoo-f0c867ddc8ce438e8da68b200b69ffb372f0ade1.tar.gz
gentoo-f0c867ddc8ce438e8da68b200b69ffb372f0ade1.tar.bz2
gentoo-f0c867ddc8ce438e8da68b200b69ffb372f0ade1.zip
dev-python/polib: version bump to 1.1.0
Diffstat (limited to 'dev-python/polib/polib-1.1.0.ebuild')
-rw-r--r--dev-python/polib/polib-1.1.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/polib/polib-1.1.0.ebuild b/dev-python/polib/polib-1.1.0.ebuild
new file mode 100644
index 000000000000..ae58824f7b11
--- /dev/null
+++ b/dev-python/polib/polib-1.1.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="A library to manipulate gettext files (.po and .mo files)"
+HOMEPAGE="https://bitbucket.org/izi/polib/wiki/Home"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc"
+
+DEPEND="doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ "${PYTHON}" tests/tests.py || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ local DOCS=( CHANGELOG README.rst )
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}