summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-10-12 08:17:19 +0200
committerMichał Górny <mgorny@gentoo.org>2021-10-12 08:18:11 +0200
commit804a7535d5c148d06ff075d27a950a4883691a9e (patch)
treec41f89ac7aeaabd063203b30bcd03f5de7bdde32 /dev-python/pooch
parentdev-python/iminuit: Bump to 2.8.4 (diff)
downloadgentoo-804a7535d5c148d06ff075d27a950a4883691a9e.tar.gz
gentoo-804a7535d5c148d06ff075d27a950a4883691a9e.tar.bz2
gentoo-804a7535d5c148d06ff075d27a950a4883691a9e.zip
dev-python/pooch: Bump to 1.5.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pooch')
-rw-r--r--dev-python/pooch/Manifest1
-rw-r--r--dev-python/pooch/pooch-1.5.2.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/pooch/Manifest b/dev-python/pooch/Manifest
index 34de6f839c2f..be1eb9d482b8 100644
--- a/dev-python/pooch/Manifest
+++ b/dev-python/pooch/Manifest
@@ -1 +1,2 @@
DIST pooch-1.4.0.tar.gz 57097 BLAKE2B c891387011c99edbb78d84a8301e18fbfce36ecf6e87372ab384921d7e608abc2db2d3b3b37229ba193f3dcebb03f8df546c266075a0a35f18856ff38b3f94e2 SHA512 f883ecbb8831a179338ad497376ced25afa812ba3fdce7db4eb85aca00368aaf7c9c9f4dd58348b24f182b59e5de52bf490f03b6d4b6a807c4dcc182ac89627b
+DIST pooch-1.5.2.tar.gz 61167 BLAKE2B 36c3ac00ae1d05b688fabc31ae9eb88536d717a3dd179a02bf76f9c8066520bc165af0a71d5cd514e7c9f2422c4a3ee189cf93215bc9a9189bf9f20a77f95e61 SHA512 acb1a48e94a97f79503125f0cf1312d715719ec32817771d2e19d2bd89b2cfd34b50221d67d1854cd93818140d8536f6f5b3db1ae0bbb185fffa2cf9886f98da
diff --git a/dev-python/pooch/pooch-1.5.2.ebuild b/dev-python/pooch/pooch-1.5.2.ebuild
new file mode 100644
index 000000000000..a8c0c03f2fed
--- /dev/null
+++ b/dev-python/pooch/pooch-1.5.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..9} )
+inherit distutils-r1
+
+DESCRIPTION="Manage your Python library's sample data files"
+HOMEPAGE="https://github.com/fatiando/pooch"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+RESTRICT="test"
+PROPERTIES="test_network"
+
+RDEPEND="
+ dev-python/appdirs[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]"
+
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/paramiko[${PYTHON_USEDEP}]
+ dev-python/pytest-localftpserver[${PYTHON_USEDEP}]
+ dev-python/tqdm[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_sphinx doc dev-python/sphinx_rtd_theme
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}