summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-09 16:21:09 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-09 17:01:16 +0200
commit14365075e2b9df19490c65edf64691cd9e6c45d5 (patch)
treec482c42801295329424b681422c1501fe8842e76 /dev-python/pretend/pretend-1.0.9-r2.ebuild
parentdev-python/setuptools_scm: Remove unnecessary virtualenv test dep (diff)
downloadgentoo-14365075e2b9df19490c65edf64691cd9e6c45d5.tar.gz
gentoo-14365075e2b9df19490c65edf64691cd9e6c45d5.tar.bz2
gentoo-14365075e2b9df19490c65edf64691cd9e6c45d5.zip
dev-python/pretend: EAPI 8, PEP517
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pretend/pretend-1.0.9-r2.ebuild')
-rw-r--r--dev-python/pretend/pretend-1.0.9-r2.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/pretend/pretend-1.0.9-r2.ebuild b/dev-python/pretend/pretend-1.0.9-r2.ebuild
new file mode 100644
index 000000000000..6b0c06303593
--- /dev/null
+++ b/dev-python/pretend/pretend-1.0.9-r2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A library for stubbing in Python"
+HOMEPAGE="
+ https://github.com/alex/pretend/
+ https://pypi.org/project/pretend/
+"
+SRC_URI="
+ https://github.com/alex/pretend/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+distutils_enable_tests pytest