summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2016-06-29 12:17:57 +0200
committerPatrick Lauer <patrick@gentoo.org>2016-06-29 12:17:57 +0200
commit6d1c23fea5cf250949424a973aeef046888a532b (patch)
tree80fa844c04dbe167a1d95e7923e36ce36377542e /dev-python/promise/promise-0.4.2.ebuild
parentdev-python/requests-cache: Bump (diff)
downloadgentoo-6d1c23fea5cf250949424a973aeef046888a532b.tar.gz
gentoo-6d1c23fea5cf250949424a973aeef046888a532b.tar.bz2
gentoo-6d1c23fea5cf250949424a973aeef046888a532b.zip
dev-python/promise: Bump
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-python/promise/promise-0.4.2.ebuild')
-rw-r--r--dev-python/promise/promise-0.4.2.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/promise/promise-0.4.2.ebuild b/dev-python/promise/promise-0.4.2.ebuild
new file mode 100644
index 000000000000..7b890dc96812
--- /dev/null
+++ b/dev-python/promise/promise-0.4.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+DISTUTILS_SINGLE_IMPL=1
+
+inherit distutils-r1
+
+DESCRIPTION="Bytecode optimisation using staticness assertions"
+HOMEPAGE="https://github.com/rfk/promise/ https://pypi.python.org/pypi/promise"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+RDEPEND="${PYTHON_DEPS}"
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
+python_test() {
+ # Timing tests fail.
+ PROMISE_SKIP_TIMING_TESTS="1" nosetests || die "tests failed"
+}