summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-06-20 06:27:19 +0200
committerMichał Górny <mgorny@gentoo.org>2024-06-20 06:45:47 +0200
commit2d23f8e207d403a0e8ff77388b74ec8f21184c81 (patch)
tree6bb913a9a85bd08ed45588a788dc168240086da6 /dev-python/proto-plus
parentdev-python/cfn-lint: Bump to 1.3.0 (diff)
downloadgentoo-2d23f8e207d403a0e8ff77388b74ec8f21184c81.tar.gz
gentoo-2d23f8e207d403a0e8ff77388b74ec8f21184c81.tar.bz2
gentoo-2d23f8e207d403a0e8ff77388b74ec8f21184c81.zip
dev-python/proto-plus: Bump to 1.24.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/proto-plus')
-rw-r--r--dev-python/proto-plus/Manifest1
-rw-r--r--dev-python/proto-plus/proto-plus-1.24.0.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/proto-plus/Manifest b/dev-python/proto-plus/Manifest
index 1fa299928dee..c4db154638f8 100644
--- a/dev-python/proto-plus/Manifest
+++ b/dev-python/proto-plus/Manifest
@@ -1 +1,2 @@
DIST proto-plus-python-1.23.0.gh.tar.gz 96752 BLAKE2B a971ef18b3513dcda0f2ea7a1eec8a1b76cc0094fdb73e7df1b258d0db7c16d2ef07152eff28c71e10456e2b9d2532da748901734d35a0245f99af7cf558866c SHA512 9e1566f6e3d2f99a37e7c5c9d3203a0073648f423112413d7d4fd61ebe38f175f30e1c4d2d24257acb7d09a685722b63960f9f686ede9ddb98a4c4463d5c0402
+DIST proto-plus-python-1.24.0.gh.tar.gz 100401 BLAKE2B 29094738e9c84559b8b51b078ecb059e7475c5c6e9392f23925c6df264efebd22c191c5b593fc659aabb20ce9cb0d93cde9df28b0b40aac4bbc80e075a95ec24 SHA512 3995df0a7df60a9a5c9325c29456f73d8482ae3d765f9553e5633b8d0ae0869c6fe3cd60e780f8fcd49d04470205abf621bc56c20d64252b76d51c19ff283372
diff --git a/dev-python/proto-plus/proto-plus-1.24.0.ebuild b/dev-python/proto-plus/proto-plus-1.24.0.ebuild
new file mode 100644
index 000000000000..ef8253d098dc
--- /dev/null
+++ b/dev-python/proto-plus/proto-plus-1.24.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+MY_P=${PN}-python-${PV}
+DESCRIPTION="Beautiful, Pythonic protocol buffers"
+HOMEPAGE="
+ https://github.com/googleapis/proto-plus-python/
+ https://pypi.org/project/proto-plus/
+"
+SRC_URI="
+ https://github.com/googleapis/proto-plus-python/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ <dev-python/protobuf-python-5[${PYTHON_USEDEP}]
+ >=dev-python/protobuf-python-3.19.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/google-api-core-1.31.5[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs \
+ dev-python/sphinx-rtd-theme