summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-12-13 20:48:35 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-12-13 21:53:27 +0200
commit0475dac26c627a34cc8baf8468ba79401bf1f6b0 (patch)
tree862d191cf94f346e56924bf4cec25518ede0dd1e /dev-python/psycopg
parentdev-python/dj-database-url: add 1.2.0 (diff)
downloadgentoo-0475dac26c627a34cc8baf8468ba79401bf1f6b0.tar.gz
gentoo-0475dac26c627a34cc8baf8468ba79401bf1f6b0.tar.bz2
gentoo-0475dac26c627a34cc8baf8468ba79401bf1f6b0.zip
dev-python/psycopg: add 3.1.5
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/psycopg')
-rw-r--r--dev-python/psycopg/Manifest1
-rw-r--r--dev-python/psycopg/psycopg-3.1.5.ebuild75
2 files changed, 76 insertions, 0 deletions
diff --git a/dev-python/psycopg/Manifest b/dev-python/psycopg/Manifest
index 51ab189f7c2c..f42169d47844 100644
--- a/dev-python/psycopg/Manifest
+++ b/dev-python/psycopg/Manifest
@@ -1,2 +1,3 @@
DIST psycopg-3.1.4.gh.tar.gz 469317 BLAKE2B a6df49a5adefbeb310602473e950ef77f0c613d8a33d41ee37dbfec544dfd014dba8dae5f78ce2bc89f2d9531ccbdd6ea07665ca638f29a4a7d0d1006bc0d778 SHA512 2bf49d6eb7e20c6f22adf47cef6dce691f38f4b310f2fbf3986f3ad14c7d390d53b9edeb3365bbf096941cc2d2affe2ddd542fe93ef37c41109742c9f9af4ba7
+DIST psycopg-3.1.5.gh.tar.gz 478528 BLAKE2B f0e6d1970b81875481bf0939d750d585f9ce4be1ccf838d1884a54d366614ec1ca76756b455d28b559ef4f49696eda68fa3b42f8c0cc18d9ce9fd1ce21029830 SHA512 006a9a6b7d34ed6f0411c33001334b9e9d29c8d1fe5e9e3b940d5664cc5c06ce10bc278ee1906a96073843ca2f8effaada8789aa390de97e543e19cc452546d1
DIST psycopg2-2.9.4.tar.gz 384017 BLAKE2B 4bc0afcc890c8a257c1ccd5c6e4e5301857a80f8b1428aa46c1473c9e18f5d2914a2e592c13336b06106217bb334d9b0321835bdd123f1627cbeb29dedf97bf7 SHA512 259088e42e0ab0d8a1a0ccf04f5e560f32c6179b4a0a0059e91bcf269baa8f4b0f1f949c332c640a2438c927a29b2c144078a861f8e18ba9c764da7c93c73b8d
diff --git a/dev-python/psycopg/psycopg-3.1.5.ebuild b/dev-python/psycopg/psycopg-3.1.5.ebuild
new file mode 100644
index 000000000000..8bd1346c397b
--- /dev/null
+++ b/dev-python/psycopg/psycopg-3.1.5.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="PostgreSQL database adapter for Python"
+HOMEPAGE="
+ https://www.psycopg.org/psycopg3/
+ https://github.com/psycopg/psycopg/
+ https://pypi.org/project/psycopg/
+"
+SRC_URI="
+ https://github.com/psycopg/psycopg/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S=${WORKDIR}/${P}/psycopg
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-solaris"
+
+DEPEND="
+ >=dev-db/postgresql-8.1:*
+"
+RDEPEND="
+ ${DEPEND}
+ $(python_gen_cond_dep '
+ >=dev-python/backports-zoneinfo-0.2.0[${PYTHON_USEDEP}]
+ ' 3.8)
+ $(python_gen_cond_dep '
+ >=dev-python/typing-extensions-4.1[${PYTHON_USEDEP}]
+ ' 3.8 3.9 3.10)
+"
+BDEPEND="
+ test? (
+ >=dev-db/postgresql-8.1[server]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/dnspython[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # tests for the psycopg_pool package
+ tests/pool
+ # some broken mypy magic
+ tests/test_module.py::test_version
+ tests/test_module.py::test_version_c
+ tests/test_typing.py
+ tests/crdb/test_typing.py
+ # TODO, relying on undefined ordering in Python?
+ tests/test_dns_srv.py::test_srv
+)
+
+src_test() {
+ # tests are lurking in top-level directory
+ cd .. || die
+
+ initdb -D "${T}"/pgsql || die
+ # TODO: random port
+ pg_ctl -w -D "${T}"/pgsql start \
+ -o "-h '' -k '${T}'" || die
+ createdb -h "${T}" test || die
+
+ local -x PSYCOPG_TEST_DSN="host=${T} dbname=test"
+ distutils-r1_src_test
+
+ pg_ctl -w -D "${T}"/pgsql stop || die
+}