summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2023-05-21 16:22:21 +0200
committerLouis Sautier <sbraz@gentoo.org>2023-05-21 16:23:31 +0200
commit064e87fda4c85c8c68de01c2f59ceeecf51e3e20 (patch)
tree976ae959ce1aa3315db9028851958fc98ee8e628 /dev-python/pulsectl
parentdev-libs/libevent: Sync the live ebuild (diff)
downloadgentoo-064e87fda4c85c8c68de01c2f59ceeecf51e3e20.tar.gz
gentoo-064e87fda4c85c8c68de01c2f59ceeecf51e3e20.tar.bz2
gentoo-064e87fda4c85c8c68de01c2f59ceeecf51e3e20.zip
dev-python/pulsectl: add 23.5.1
Signed-off-by: Louis Sautier <sbraz@gentoo.org> Closes: https://bugs.gentoo.org/906813
Diffstat (limited to 'dev-python/pulsectl')
-rw-r--r--dev-python/pulsectl/Manifest1
-rw-r--r--dev-python/pulsectl/pulsectl-23.5.1.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/pulsectl/Manifest b/dev-python/pulsectl/Manifest
index 3458503004da..34929a518307 100644
--- a/dev-python/pulsectl/Manifest
+++ b/dev-python/pulsectl/Manifest
@@ -1 +1,2 @@
DIST pulsectl-22.3.2.tar.gz 40901 BLAKE2B 5b3eb752865e95cfbb70a7228409fea70b4c55c7297d652b4614df7ea4764dcb446f7a3e25bb89f6a55badbf6b300381c7c28c56f0a47e7faf1e63003f39d02c SHA512 7fc11c792a9e586d191a32831e0ef8896c40da1fdeddfd4467d7ec352e5e0ef0c910d7a2e8e82e1a381b16afefa17c9c9db4821be74d4694c934337b2a862f0c
+DIST pulsectl-23.5.1.tar.gz 41131 BLAKE2B 4e24a0d79d2f5c5a365a23643019150693862a636115a0fcf26dbc64cf9d80a8637c1f03193f8d2513660e8f5268946ef287d01b93b7fd3a416dbb05b2c619f0 SHA512 69516e1d64cb2e27643de6fcb273b621ab89a03dd5c40eb71a7fa6b846da96f8f10baacf794c73edc3f60f65787c7050c16c234aa5b23169c2d5ae815232372a
diff --git a/dev-python/pulsectl/pulsectl-23.5.1.ebuild b/dev-python/pulsectl/pulsectl-23.5.1.ebuild
new file mode 100644
index 000000000000..a13a963b83ea
--- /dev/null
+++ b/dev-python/pulsectl/pulsectl-23.5.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python high-level interface and ctypes-based bindings for PulseAudio (libpulse)"
+HOMEPAGE="
+ https://github.com/mk-fg/python-pulse-control/
+ https://pypi.org/project/pulsectl/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ media-sound/pulseaudio
+"
+BDEPEND="
+ test? (
+ media-sound/pulseaudio-daemon
+ )
+"
+
+distutils_enable_tests unittest