summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/pupynere
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/pupynere')
-rw-r--r--dev-python/pupynere/Manifest1
-rw-r--r--dev-python/pupynere/metadata.xml10
-rw-r--r--dev-python/pupynere/pupynere-1.0.15-r1.ebuild28
3 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/pupynere/Manifest b/dev-python/pupynere/Manifest
new file mode 100644
index 000000000000..bc8dd53d7883
--- /dev/null
+++ b/dev-python/pupynere/Manifest
@@ -0,0 +1 @@
+DIST pupynere-1.0.15.tar.gz 8566 SHA256 b759b501406c950b576de1880f1dc080e05536ae42299267093e2379dac9086d SHA512 55b25ca4fb511d80b5eb11b8aa63949c80e9dda336ed1ad406314bbda669ee4ef836a3e01b71065eec0cf0b8556ef36c815a299a5620d50983074a2ff55ca5ba WHIRLPOOL 1dd1e7675c6d147035613e2b549ddf5cae4d6645c75f274691b350afa99e961f5cfaba75bba81b1a80b9057a798df7a531c122af086ac5263d76f95f736db2a3
diff --git a/dev-python/pupynere/metadata.xml b/dev-python/pupynere/metadata.xml
new file mode 100644
index 000000000000..4b41f58210e1
--- /dev/null
+++ b/dev-python/pupynere/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+ <longdescription lang="en">Pupynere is a Python module for reading and writing NetCDF files,
+ using the same API as Scientific.IO.NetCDF and pynetcdf.</longdescription>
+ <upstream>
+ <remote-id type="pypi">pupynere</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pupynere/pupynere-1.0.15-r1.ebuild b/dev-python/pupynere/pupynere-1.0.15-r1.ebuild
new file mode 100644
index 000000000000..6e4bedbdfdbf
--- /dev/null
+++ b/dev-python/pupynere/pupynere-1.0.15-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Pupynere is a PUre PYthon NEtcdf REader"
+HOMEPAGE="http://pypi.python.org/pypi/pupynere/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="dev-python/numpy[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ cd "${BUILD_DIR}" || die
+ "${PYTHON}" -m doctest -v "${BUILD_DIR}"/lib/pupynere.py \
+ || die "Tests fail with ${EPYTHON}"
+}