summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-03-26 21:05:31 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-03-26 21:05:31 +0300
commita2c7a88ecab1484b2e58e69cabb42d3339fa1c9c (patch)
tree974a7806fefff7e4ae27ff08c0e4e2146d9a77f6 /dev-python/pybind11
parentdev-python/cryptography: Stabilize 3.4.7-r3 ppc, #836198 (diff)
downloadgentoo-a2c7a88ecab1484b2e58e69cabb42d3339fa1c9c.tar.gz
gentoo-a2c7a88ecab1484b2e58e69cabb42d3339fa1c9c.tar.bz2
gentoo-a2c7a88ecab1484b2e58e69cabb42d3339fa1c9c.zip
dev-python/pybind11: drop 2.9.0
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/pybind11')
-rw-r--r--dev-python/pybind11/Manifest1
-rw-r--r--dev-python/pybind11/pybind11-2.9.0.ebuild53
2 files changed, 0 insertions, 54 deletions
diff --git a/dev-python/pybind11/Manifest b/dev-python/pybind11/Manifest
index 042de689a969..7d84a59cbea8 100644
--- a/dev-python/pybind11/Manifest
+++ b/dev-python/pybind11/Manifest
@@ -1,2 +1 @@
-DIST pybind11-2.9.0.tar.gz 698784 BLAKE2B bfbe173d580131e445d759bd9b1a8929ceb9fc357a1ed8873aa8024fb9226a37bb97293dc0189a67ae61a232f3790ca6f635a30d0a0401c867cde98f1010438c SHA512 87184c9e09e1340f2d34786a66560fe77684a3629b517f78321073a1f0dfdb766365d3698dcf6f08e5141b1f4da50ec917e61b36538e5a1ec9fd1b68f29cd396
DIST pybind11-2.9.1.tar.gz 703882 BLAKE2B cc162332b637f81ea5d3098a2e9882f16a9c889e83e6ccd36d2a2da2f90361d8d188abd559f2313b45ff1de7d9ee56ee198c1193b47829d1fdf6d8871ce35b0c SHA512 1f268cc6df1f572658bfc3e60f7f010bec9b9444d6a6d6c95f7b26f7b4b7dd42846e65ae5a611c01c0341335fdfa84b01272b5c1b2cc11a418f64fecabfa0588
diff --git a/dev-python/pybind11/pybind11-2.9.0.ebuild b/dev-python/pybind11/pybind11-2.9.0.ebuild
deleted file mode 100644
index 6dbfed6ba055..000000000000
--- a/dev-python/pybind11/pybind11-2.9.0.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-inherit cmake distutils-r1
-
-DESCRIPTION="AST-based Python refactoring library"
-HOMEPAGE="https://pybind11.readthedocs.io/en/stable/"
-SRC_URI="https://github.com/pybind/pybind11/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ppc ppc64 ~riscv ~s390 ~sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
-
-RDEPEND="
- dev-cpp/eigen:3
-"
-
-distutils_enable_tests pytest
-
-python_prepare_all() {
- export PYBIND11_USE_CMAKE=1
-
- cmake_src_prepare
- distutils-r1_python_prepare_all
-}
-
-python_configure() {
- local mycmakeargs=(
- # disable forced lto
- -DPYBIND11_LTO_CXX_FLAGS=
- -DPYBIND11_INSTALL=ON
- -DPYBIND11_TEST=$(usex test)
- )
- cmake_src_configure
-}
-
-python_compile() {
- distutils-r1_python_compile
- # Compilation only does anything for tests
- use test && cmake_src_compile
-}
-
-python_test() {
- cmake_build check
-}
-
-python_install() {
- distutils-r1_python_install
- cmake_src_install
-}