summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-05-13 17:12:36 +0200
committerMichał Górny <mgorny@gentoo.org>2021-05-13 17:12:36 +0200
commit96c1b9b3b13022fd5477b2171230cc17026443b1 (patch)
tree9e3e1ca2e62d360eeef24bd827c6c0e7b323f082 /dev-python/pydantic/pydantic-1.8.1.ebuild
parentvirtual/rust: enable riscv support (diff)
downloadgentoo-96c1b9b3b13022fd5477b2171230cc17026443b1.tar.gz
gentoo-96c1b9b3b13022fd5477b2171230cc17026443b1.tar.bz2
gentoo-96c1b9b3b13022fd5477b2171230cc17026443b1.zip
dev-python/pydantic: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pydantic/pydantic-1.8.1.ebuild')
-rw-r--r--dev-python/pydantic/pydantic-1.8.1.ebuild41
1 files changed, 0 insertions, 41 deletions
diff --git a/dev-python/pydantic/pydantic-1.8.1.ebuild b/dev-python/pydantic/pydantic-1.8.1.ebuild
deleted file mode 100644
index 26b8dccc514f..000000000000
--- a/dev-python/pydantic/pydantic-1.8.1.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..9} )
-
-inherit distutils-r1
-
-DESCRIPTION="Data parsing and validation using Python type hints"
-HOMEPAGE="https://github.com/samuelcolvin/pydantic"
-# No tests on PyPI: https://github.com/samuelcolvin/pydantic/pull/1976
-SRC_URI="https://github.com/samuelcolvin/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="
- dev-python/typing-extensions[${PYTHON_USEDEP}]
-"
-BDEPEND="
- dev-python/cython[${PYTHON_USEDEP}]
- test? (
- dev-python/pytest-mock[${PYTHON_USEDEP}]
- dev-python/python-email-validator[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- # seriously?
- sed -i -e '/CFLAGS/d' setup.py || die
- distutils-r1_src_prepare
-}
-
-python_test() {
- # TODO
- epytest --deselect tests/test_hypothesis_plugin.py
-}