summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-07-13 06:18:16 +0200
committerMichał Górny <mgorny@gentoo.org>2024-07-13 06:44:50 +0200
commit89eb4d8555c21f66beec4f83286dce506a9d7f3f (patch)
tree20455213ccb86314f3b63127aae385249373bad6 /dev-python/pydyf
parentdev-python/cfn-lint: Bump to 1.6.1 (diff)
downloadgentoo-89eb4d8555c21f66beec4f83286dce506a9d7f3f.tar.gz
gentoo-89eb4d8555c21f66beec4f83286dce506a9d7f3f.tar.bz2
gentoo-89eb4d8555c21f66beec4f83286dce506a9d7f3f.zip
dev-python/pydyf: Bump to 0.11.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pydyf')
-rw-r--r--dev-python/pydyf/Manifest1
-rw-r--r--dev-python/pydyf/pydyf-0.11.0.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/pydyf/Manifest b/dev-python/pydyf/Manifest
index 1329c4921716..d87af3b58e26 100644
--- a/dev-python/pydyf/Manifest
+++ b/dev-python/pydyf/Manifest
@@ -1 +1,2 @@
DIST pydyf-0.10.0.tar.gz 17615 BLAKE2B e378f26ab2dc4d904762d967c0552f3a9d96248c0fd2687669f22c0ee3af5d35cf59c60f0dc0b015a4d1cd098a2de01d102cbf16e8c5d48b3f56299b36c55884 SHA512 7c35a818569dda0edb0dda5e31c595a65e2637594a7a6815ef3b41e34c10a4f2a1b3412af59f48fee2e72e8bf23c01e651b46130e1927645cbafc7d99c104574
+DIST pydyf-0.11.0.tar.gz 17769 BLAKE2B 5fa6d597592104a505267a29ad99cf0c06e84e165a407438563982d45f3d77d9c2a0c45ffda2c16fe6f8656ca406f3bff8ad7dc19f011132334130fcb0c5bc1d SHA512 f02021d1d6bb59557a5b1c1a7f71551b1efe0f8019b2d2e28a84fb126b0d4b701e884971376b8a7b654a51f1831b3fab319a0212e9cb444a392304fc244133d1
diff --git a/dev-python/pydyf/pydyf-0.11.0.ebuild b/dev-python/pydyf/pydyf-0.11.0.ebuild
new file mode 100644
index 000000000000..c726d36d516c
--- /dev/null
+++ b/dev-python/pydyf/pydyf-0.11.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A low-level PDF generator"
+HOMEPAGE="
+ https://pypi.org/project/pydyf/
+ https://github.com/CourtBouillon/pydyf/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ test? (
+ app-text/ghostscript-gpl
+ dev-python/pillow[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest