summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/pyface
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/pyface')
-rw-r--r--dev-python/pyface/Manifest2
-rw-r--r--dev-python/pyface/metadata.xml20
-rw-r--r--dev-python/pyface/pyface-4.3.0-r1.ebuild60
-rw-r--r--dev-python/pyface/pyface-4.4.0.ebuild44
4 files changed, 126 insertions, 0 deletions
diff --git a/dev-python/pyface/Manifest b/dev-python/pyface/Manifest
new file mode 100644
index 000000000000..66375a48864e
--- /dev/null
+++ b/dev-python/pyface/Manifest
@@ -0,0 +1,2 @@
+DIST pyface-4.3.0.tar.gz 5062628 SHA256 e95e1991231a269324e59ecb0950a3d3ce4aa0cd1ab40d0b301cc8324e502d75 SHA512 14ef540408b5258bdb2efd97873f5c9cbc7ab0110c5a5c71ed5ebcf9b8cd8abbc011666fbacb99ce5bb2ac0ae55dbef731a32ec32cb9bb94107203e6a43862fc WHIRLPOOL 0fa3e35966cf941ca34bafdc2fed551b2b9a1d105f9c3daa2ea2ee8040cf9b491921d67cb007083a063f1c97695855cf4785511353df199bf26250d2242ac202
+DIST pyface-4.4.0.tar.gz 486490 SHA256 270bc35a5364681b78569619917e1b5890150c882b455b52578f0c0752f3d3fc SHA512 62c93cbd5e956d56c03580876d5f9191210beb3d81cf8fcd0dfc6b2919263e4bf01219f1372e292fcac4462eaffb45cf9cde62dbe16265134b357dabc47d719d WHIRLPOOL 0596a09dad5a026c5726ef18b2c507a8adba1c2783d91f81cae0d5238b0d206f8486120c11824e6494153314749cfb812434e5e7c5ccd29cd231b2b2c9460aab
diff --git a/dev-python/pyface/metadata.xml b/dev-python/pyface/metadata.xml
new file mode 100644
index 000000000000..9acace48f165
--- /dev/null
+++ b/dev-python/pyface/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <longdescription lang="en">
+ The pyface project contains a toolkit-independent GUI abstraction
+ layer, which is used to support the "visualization" features of the
+ Traits package. Thus, you can write code in terms of the Traits API
+ (views, items, editors, etc.), and let pyface and your selected
+ toolkit and back-end take care of the details of displaying them.
+ The following GUI backends are supported:
+ * wxPython
+ * PyQt
+ * PySide
+</longdescription>
+ <upstream>
+ <remote-id type="pypi">pyface</remote-id>
+ <remote-id type="github">enthought/pyface</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pyface/pyface-4.3.0-r1.ebuild b/dev-python/pyface/pyface-4.3.0-r1.ebuild
new file mode 100644
index 000000000000..7dab97ae079a
--- /dev/null
+++ b/dev-python/pyface/pyface-4.3.0-r1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# https://github.com/enthought/pyface/issues/40 confirms only py2.7
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Enthought Tool Suite: Traits-capable windowing framework"
+HOMEPAGE="https://github.com/enthought/pyface http://pypi.python.org/pypi/pyface"
+SRC_URI="http://www.enthought.com/repo/ets/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples test"
+
+RDEPEND="
+ >=dev-python/traits-4.1[${PYTHON_USEDEP}]
+ || (
+ dev-python/wxpython:*[${PYTHON_USEDEP}]
+ dev-python/PyQt4[${PYTHON_USEDEP}]
+ dev-python/pyside[${PYTHON_USEDEP}]
+ )"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? (
+ ${RDEPEND}
+ dev-python/traitsui[${PYTHON_USEDEP}]
+ media-fonts/font-cursor-misc
+ media-fonts/font-misc-misc
+ )"
+
+DOCS=( docs/*.txt )
+
+python_compile_all() {
+ use doc && virtualmake -C docs html
+}
+
+python_test() {
+ export ETS_TOOLKIT=qt4
+ export QT_API=pyqt
+ # set nosetests to ignore tests unpassable by these vars.
+ VIRTUALX_COMMAND="nosetests" virtualmake -v -I 'composite_grid_model_test_case*' \
+ -I 'simple_grid_model_test_case*' \
+ -I 'test_split_editor_area_pane*'
+}
+
+python_install_all() {
+ find -name "*LICENSE*.txt" -delete
+ use doc && dohtml -r docs/build/html/*
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}
diff --git a/dev-python/pyface/pyface-4.4.0.ebuild b/dev-python/pyface/pyface-4.4.0.ebuild
new file mode 100644
index 000000000000..72fc2ef1f695
--- /dev/null
+++ b/dev-python/pyface/pyface-4.4.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# https://github.com/enthought/pyface/issues/40 confirms only py2.7
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Enthought Tool Suite: Traits-capable windowing framework"
+HOMEPAGE="https://github.com/enthought/pyface"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/traits-4.1[${PYTHON_USEDEP}]
+ || (
+ dev-python/wxpython:*[${PYTHON_USEDEP}]
+ dev-python/PyQt4[${PYTHON_USEDEP}]
+ dev-python/pyside[${PYTHON_USEDEP}]
+ )"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/traitsui[${PYTHON_USEDEP}]
+ media-fonts/font-cursor-misc
+ media-fonts/font-misc-misc
+ )"
+
+python_test() {
+ export ETS_TOOLKIT=qt4
+ export QT_API=pyqt
+ # set nosetests to ignore tests unpassable by these vars.
+ VIRTUALX_COMMAND="nosetests" virtualmake -v -I 'composite_grid_model_test_case*' \
+ -I 'simple_grid_model_test_case*' \
+ -I 'test_split_editor_area_pane*'
+}