summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-10-12 06:31:45 +0200
committerMichał Górny <mgorny@gentoo.org>2023-10-12 06:31:45 +0200
commitb05345d347f480562d47411c3b723904462782a6 (patch)
tree2118c39c0f189a6f30418101b4a00ca639914ef9 /dev-python/pyfakefs
parentdev-python/Faker: Bump to 19.10.0 (diff)
downloadgentoo-b05345d347f480562d47411c3b723904462782a6.tar.gz
gentoo-b05345d347f480562d47411c3b723904462782a6.tar.bz2
gentoo-b05345d347f480562d47411c3b723904462782a6.zip
dev-python/pyfakefs: Bump to 5.3.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyfakefs')
-rw-r--r--dev-python/pyfakefs/Manifest1
-rw-r--r--dev-python/pyfakefs/pyfakefs-5.3.0.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/pyfakefs/Manifest b/dev-python/pyfakefs/Manifest
index a8ebafa43999..03a69c8d1c68 100644
--- a/dev-python/pyfakefs/Manifest
+++ b/dev-python/pyfakefs/Manifest
@@ -1 +1,2 @@
DIST pyfakefs-5.2.4.gh.tar.gz 222882 BLAKE2B 780f3952886dfb263be97fbcaa99ed0f0bcb804b075b71822d8a5b0db2bd1e12c57daf88b96d3eb8eb4b7fefdde6fb343cec8429bcf4380e4981bea7ca4f780d SHA512 2b933c420393b329d2c3ac6523e650124cce84424e298e1525591be02033d1bbb5d5cc354170ac6875d63e1729f6f79edcf8400d1cb0e419c586ae1cdd491baa
+DIST pyfakefs-5.3.0.gh.tar.gz 224241 BLAKE2B de6d1b420bcfe710bef00c4f8d9cd4fa838341a7285d89a02607701f0011ccbe7f1974c5eec502994f787661496f74332bc4d4aa3389023ae02607a968c33be5 SHA512 25d967390f66ba5881429a37b62110ef129aae989efe66740c3a04fccfcbc601476d23427ac23d5df82a1e1a8102d557f0cca39b94fa0c7e69b6dca80d1e435e
diff --git a/dev-python/pyfakefs/pyfakefs-5.3.0.ebuild b/dev-python/pyfakefs/pyfakefs-5.3.0.ebuild
new file mode 100644
index 000000000000..3c6dcae279a5
--- /dev/null
+++ b/dev-python/pyfakefs/pyfakefs-5.3.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A fake file system that mocks the Python file system modules"
+HOMEPAGE="
+ https://github.com/pytest-dev/pyfakefs/
+ https://pypi.org/project/pyfakefs/
+"
+SRC_URI="
+ https://github.com/pytest-dev/pyfakefs/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ # test for regression with opentimelineio package
+ pyfakefs/pytest_tests/segfault_test.py
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p pyfakefs.pytest_plugin
+}