summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-11-19 10:24:24 +0100
committerMichał Górny <mgorny@gentoo.org>2023-11-19 10:44:34 +0100
commitdd78c6a3cda00f918dd82f8090a82c2695bb60c6 (patch)
tree62d9fb07a81874ee64c34d6a709d72883411d3a3 /dev-python/pyfakefs
parentdev-python/pyfakefs: Deselect a regressing test on py3.12 (diff)
downloadgentoo-dd78c6a3cda00f918dd82f8090a82c2695bb60c6.tar.gz
gentoo-dd78c6a3cda00f918dd82f8090a82c2695bb60c6.tar.bz2
gentoo-dd78c6a3cda00f918dd82f8090a82c2695bb60c6.zip
dev-python/pyfakefs: Bump to 5.3.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyfakefs')
-rw-r--r--dev-python/pyfakefs/Manifest1
-rw-r--r--dev-python/pyfakefs/pyfakefs-5.3.1.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/pyfakefs/Manifest b/dev-python/pyfakefs/Manifest
index f81f5fd28755..fee4178481bd 100644
--- a/dev-python/pyfakefs/Manifest
+++ b/dev-python/pyfakefs/Manifest
@@ -1 +1,2 @@
DIST pyfakefs-5.3.0.gh.tar.gz 224241 BLAKE2B de6d1b420bcfe710bef00c4f8d9cd4fa838341a7285d89a02607701f0011ccbe7f1974c5eec502994f787661496f74332bc4d4aa3389023ae02607a968c33be5 SHA512 25d967390f66ba5881429a37b62110ef129aae989efe66740c3a04fccfcbc601476d23427ac23d5df82a1e1a8102d557f0cca39b94fa0c7e69b6dca80d1e435e
+DIST pyfakefs-5.3.1.gh.tar.gz 225234 BLAKE2B 2688a40ce22a112ce80de8795e3c0b0dd7e2cd46b41c442c5e13085ec614e323a5558cfa48e0e5c79c7c418a739b3f0a6202bb007e8c201ac3fbcc3b209a3d9f SHA512 6d2b16327e8f40d98ac84ea8662dc359aa1b590e1de71761d511b084268d44ee2950cd2af1ec4e722fcb6e7dd14b93e01969fa5cc12e178e97ca2ce69073deea
diff --git a/dev-python/pyfakefs/pyfakefs-5.3.1.ebuild b/dev-python/pyfakefs/pyfakefs-5.3.1.ebuild
new file mode 100644
index 000000000000..d5a9d7aac337
--- /dev/null
+++ b/dev-python/pyfakefs/pyfakefs-5.3.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A fake file system that mocks the Python file system modules"
+HOMEPAGE="
+ https://github.com/pytest-dev/pyfakefs/
+ https://pypi.org/project/pyfakefs/
+"
+SRC_URI="
+ https://github.com/pytest-dev/pyfakefs/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=()
+ local EPYTEST_IGNORE=(
+ # test for regression with opentimelineio package
+ pyfakefs/pytest_tests/segfault_test.py
+ )
+
+ case ${EPYTHON} in
+ python3.12)
+ EPYTEST_DESELECT+=(
+ # happens with pandas + zstandard [cffi backend]
+ # https://github.com/pytest-dev/pyfakefs/issues/910
+ pyfakefs/tests/patched_packages_test.py::TestPatchedPackages::test_read_{csv,table}
+ )
+ ;;
+ esac
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p pyfakefs.pytest_plugin
+}