summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-04-10 09:24:12 +0200
committerMichał Górny <mgorny@gentoo.org>2022-04-10 10:58:06 +0200
commit55caa1cfec738d6dba6c9dd3ccafeb28ddc89f0d (patch)
treec306f4b90fc6c8a89cc9a4c8a3ed472e5d72686e /dev-python/pyparsing
parentdev-python/hypothesis: Bump to 6.42.2 (diff)
downloadgentoo-55caa1cfec738d6dba6c9dd3ccafeb28ddc89f0d.tar.gz
gentoo-55caa1cfec738d6dba6c9dd3ccafeb28ddc89f0d.tar.bz2
gentoo-55caa1cfec738d6dba6c9dd3ccafeb28ddc89f0d.zip
dev-python/pyparsing: Bump to 3.0.8
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyparsing')
-rw-r--r--dev-python/pyparsing/Manifest1
-rw-r--r--dev-python/pyparsing/pyparsing-3.0.8.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/pyparsing/Manifest b/dev-python/pyparsing/Manifest
index ee6f4f744636..48526d4e4da8 100644
--- a/dev-python/pyparsing/Manifest
+++ b/dev-python/pyparsing/Manifest
@@ -1 +1,2 @@
DIST pyparsing_3.0.7.tar.gz 944917 BLAKE2B bcbcd18817c69a69ac6863affb1309a5ca63fe46a45dc056d8407d79a77d1f19e4d1abce08f5d6f1aff7cbdaefb5b699787abcddfcbf64e5514e79e2b0b86ce6 SHA512 d5d5547188ebda6fb7f45928174314d3d4d10302acc8fb476cd6590fb4a75167dee5f6397ab0b63efd4cb55c0765708ffd432bcfecf28d8f808815e62615f447
+DIST pyparsing_3.0.8.tar.gz 948516 BLAKE2B 8df61ce3c5f0b9ef725bf750fa25c26e482a5786b6c3a03befbf7945c76f67981d0f60bfc98badeb353274e5e3c8442e105ae635d0b93681e23090e70716ce0a SHA512 5567824ac6d4c17755c0d47f2994cc2449383d9d3e9dfa374886d92af38651334483034713df420701d1c4560b331f61d763f7f8d1d7a14a7d221c022b9fc8a7
diff --git a/dev-python/pyparsing/pyparsing-3.0.8.ebuild b/dev-python/pyparsing/pyparsing-3.0.8.ebuild
new file mode 100644
index 000000000000..0c8cb9eb70bc
--- /dev/null
+++ b/dev-python/pyparsing/pyparsing-3.0.8.ebuild
@@ -0,0 +1,46 @@
+# Copyright 2004-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# please keep this ebuild at EAPI 7 -- sys-apps/portage dep
+EAPI=7
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+MY_P=${P/-/_}
+DESCRIPTION="Easy-to-use Python module for text parsing"
+HOMEPAGE="https://github.com/pyparsing/pyparsing https://pypi.org/project/pyparsing/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${MY_P}.tar.gz"
+S="${WORKDIR}/${PN}-${MY_P}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="examples"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # railroad-diagrams not packaged (and not suitable for packaging yet)
+ tests/test_diagram.py
+)
+
+EPYTEST_DESELECT=(
+ # also railroad-diagrams
+ tests/test_unit.py::Test02_WithoutPackrat::testEmptyExpressionsAreHandledProperly
+ tests/test_unit.py::Test04_WithPackrat::testEmptyExpressionsAreHandledProperly
+ tests/test_unit.py::Test06_WithBoundedPackrat::testEmptyExpressionsAreHandledProperly
+ tests/test_unit.py::Test08_WithUnboundedPackrat::testEmptyExpressionsAreHandledProperly
+ tests/test_unit.py::Test09_WithLeftRecursionParsing::testEmptyExpressionsAreHandledProperly
+ tests/test_unit.py::Test10_WithLeftRecursionParsingBoundedMemo::testEmptyExpressionsAreHandledProperly
+)
+
+python_install_all() {
+ if use examples; then
+ docompress -x /usr/share/doc/${PF}/examples
+ dodoc -r examples
+ fi
+ distutils-r1_python_install_all
+}