summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-03-07 07:00:36 +0100
committerMichał Górny <mgorny@gentoo.org>2023-03-07 08:06:42 +0100
commitd44acc1982d547e87d937d0f280370d2afd3fc84 (patch)
treee3df7a83cf1b57ae4b42ac9ad6bb812801c4bf09 /dev-python/pypdf
parentdev-python/hvac: Bump to 1.1.0 (diff)
downloadgentoo-d44acc1982d547e87d937d0f280370d2afd3fc84.tar.gz
gentoo-d44acc1982d547e87d937d0f280370d2afd3fc84.tar.bz2
gentoo-d44acc1982d547e87d937d0f280370d2afd3fc84.zip
dev-python/pypdf: Bump to 3.5.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pypdf')
-rw-r--r--dev-python/pypdf/Manifest2
-rw-r--r--dev-python/pypdf/pypdf-3.5.1.ebuild60
2 files changed, 62 insertions, 0 deletions
diff --git a/dev-python/pypdf/Manifest b/dev-python/pypdf/Manifest
index 0c4ead2a4c43..2e163b75b80a 100644
--- a/dev-python/pypdf/Manifest
+++ b/dev-python/pypdf/Manifest
@@ -2,4 +2,6 @@ DIST pypdf-3.3.0.gh.tar.gz 6803536 BLAKE2B ff70995882581c816fbf7410232c68e964963
DIST pypdf-3.4.0.gh.tar.gz 6931831 BLAKE2B 037ac998cc1e3d078281b64183197678a80345731f6d4691b00f9e546eb61eaa34c4d7f4b704191c887975517da73359983f1b7405776e99257f79b1604dafc0 SHA512 9bee70a039c42533b600f1e95e28a4889d7df212bae18deca7d88501008d3a3e2b4d7fe36134e947cb14b0acc650126688c358ce2b662917a4c6df46241db1ab
DIST pypdf-3.4.1.gh.tar.gz 6930245 BLAKE2B 9e8a5a1ebe95b64c9274ce6b0ea252d65f41d4b6791d6c6acf87f810794892337aed13ddc9b77f05a404fe94b3d9c2444f2a06c4feea9661204e71684bbbbfd5 SHA512 e2e3fa74bc6e96afc5999429e7603dd3ab8e6443b6259e456bc6d90cb2d7a15a484b226e218478c1e92cfd7fe23c93247f212568c6fcd51d80afde32b83460ba
DIST pypdf-3.5.0.gh.tar.gz 7181507 BLAKE2B 8f5c129613ed12a9eaa90cf0e6fa189b0fc5bf109f26b8cc35ff1550e916b0635715359b2ece9c3c0243095c2e802474e99fe4c59d16b0f75b4375fb2ce07e5d SHA512 a8a0fad3fd08d88738088a06df4f1cbf419571e9e817c6097ce8bdcf7b1dd32f478ac712879cabceb7034f4e9a421f887ff117a1812782eadb670c8043aff86c
+DIST pypdf-3.5.1.gh.tar.gz 7183874 BLAKE2B 29ce7d052f0c466e72974ec051e149c2383136cc0097e2e104c4c1e5c37836f7908b25bfaa32e5fd85082f860b06ad88adbfbb5bbff95bc7a735e127b26d7964 SHA512 4f28cc0822f472087f096b4b2ee553b87e458009b29c43d41bbba53de9862292c78f4b31a860d4c783a6af4f92fdf32612bab7a42190373d9d9ceae39080bb35
DIST pypdf-sample-files-0fe84b30ed33ff3daa9293e44349b8618f135699.gh.tar.gz 9027166 BLAKE2B 912bb9fbd632bd0ad2cc2e865a1e6870ad7064aa2cf4d6f96217f63ac685e9a511f0bb20c22d48ae970a2eb171b27a0fa680fa42892425531f69735840cf741b SHA512 07a71a3566dabcea5dc8a549949d0f0c0f9483d5d9f85851d6e4e702dd374b348469a80e5300d18983e560ee9a44d0639b55eb338023b9ebbdb26c6f8c455e07
+DIST pypdf-sample-files-fb7a080b35b3553bd10221282beeda7847959e83.gh.tar.gz 9027029 BLAKE2B 8f8797263b86f08efd9708d5812000efd08708abf66a0e95f50f5a147102e555dd7f8c465ae73cae842d86efdb52cabba5f8962626f56cb1b98409bfa108e150 SHA512 3a9cdab964a14cf6b14d80d917441a4e5effe2b7647163b666781ecabd189624dbbe5039111f6b1d753ff73e013665a1b86d87ca7806580fda58ec5810f88e94
diff --git a/dev-python/pypdf/pypdf-3.5.1.ebuild b/dev-python/pypdf/pypdf-3.5.1.ebuild
new file mode 100644
index 000000000000..246ddfc145ee
--- /dev/null
+++ b/dev-python/pypdf/pypdf-3.5.1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+SAMPLE_COMMIT=fb7a080b35b3553bd10221282beeda7847959e83
+DESCRIPTION="Python library to work with PDF files"
+HOMEPAGE="
+ https://pypi.org/project/pypdf/
+ https://github.com/py-pdf/pypdf/
+"
+SRC_URI="
+ https://github.com/py-pdf/pypdf/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ test? (
+ https://github.com/py-pdf/sample-files/archive/${SAMPLE_COMMIT}.tar.gz
+ -> ${PN}-sample-files-${SAMPLE_COMMIT}.gh.tar.gz
+ )
+"
+S=${WORKDIR}/pypdf-${PV}
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ ' 3.8 3.9)
+"
+BDEPEND="
+ dev-python/pillow[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pycryptodome[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # rely on -Werror
+ tests/test_utils.py::test_deprecate_no_replacement
+ tests/test_workflows.py::test_orientations
+)
+
+src_unpack() {
+ default
+ if use test; then
+ mv "sample-files-${SAMPLE_COMMIT}"/* "${S}"/sample-files/ || die
+ fi
+}
+
+python_test() {
+ epytest -o addopts= -m "not enable_socket"
+}