summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-09-23 08:29:50 +0200
committerMichał Górny <mgorny@gentoo.org>2021-09-23 10:16:13 +0200
commit1a8c766db3dba05220d685af8e45b29031aaa734 (patch)
tree0d6af8776c72acfd13608f121b9bce3bb25a5f87 /dev-python/pyscard/pyscard-2.0.2.ebuild
parentdev-python/flask-security: Bump to 4.1.2 (diff)
downloadgentoo-1a8c766db3dba05220d685af8e45b29031aaa734.tar.gz
gentoo-1a8c766db3dba05220d685af8e45b29031aaa734.tar.bz2
gentoo-1a8c766db3dba05220d685af8e45b29031aaa734.zip
dev-python/pyscard: Bump to 2.0.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyscard/pyscard-2.0.2.ebuild')
-rw-r--r--dev-python/pyscard/pyscard-2.0.2.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/pyscard/pyscard-2.0.2.ebuild b/dev-python/pyscard/pyscard-2.0.2.ebuild
new file mode 100644
index 000000000000..3ca571fac574
--- /dev/null
+++ b/dev-python/pyscard/pyscard-2.0.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Smart card support in python"
+HOMEPAGE="https://pyscard.sourceforge.io/
+ https://github.com/LudovicRousseau/pyscard
+ https://pypi.org/project/pyscard/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~riscv ~x86"
+
+RDEPEND="sys-apps/pcsc-lite"
+DEPEND="${RDEPEND}"
+BDEPEND="dev-lang/swig"
+
+distutils_enable_tests setup.py
+
+pkg_postinst() {
+ optfeature "Gui support" dev-python/wxpython
+ optfeature "Support of remote readers with Pyro" dev-python/Pyro4
+}