summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-03-10 04:26:40 +0100
committerMichał Górny <mgorny@gentoo.org>2024-03-10 04:26:40 +0100
commit458071ccfe7a2ca6d11d853147b8dfe4990bc217 (patch)
treec1d2364a729bc52a3fb9bd58d18a81b784284369 /dev-python/pyscard
parentdev-python/apprise: Bump to 1.7.4 (diff)
downloadgentoo-458071ccfe7a2ca6d11d853147b8dfe4990bc217.tar.gz
gentoo-458071ccfe7a2ca6d11d853147b8dfe4990bc217.tar.bz2
gentoo-458071ccfe7a2ca6d11d853147b8dfe4990bc217.zip
dev-python/pyscard: Bump to 2.0.8
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyscard')
-rw-r--r--dev-python/pyscard/Manifest1
-rw-r--r--dev-python/pyscard/pyscard-2.0.8.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/pyscard/Manifest b/dev-python/pyscard/Manifest
index 5d250a934bb2..52be3d0cb2e0 100644
--- a/dev-python/pyscard/Manifest
+++ b/dev-python/pyscard/Manifest
@@ -1 +1,2 @@
DIST pyscard-2.0.7.tar.gz 152304 BLAKE2B 8be34283b85b830597f051fedcdbe4437b81ad6ecf9dc0304e5bbb74f9af4fec36acc8d843802d59a204d75a4792f74827b5f422a9452cb0d84fe0ed51e4c2b3 SHA512 d30a2d0fe9b410f277a4a1e45ae88a30eb3aa7ef6cac683a80d2bb3cfe38aeafe6a483dfd42c50017c46ee0d26da13f7226e25e783176587eafce1988127bb67
+DIST pyscard-2.0.8.tar.gz 153266 BLAKE2B 524b060ffa869ac4d739cd26d795c559b7c2ab26aa7f687e7b9392508c0e768f9b8442a0d4ebfd0f2903eca922a7cf1cedbe54f78c77f39a4635739a914713d7 SHA512 245602aaab024a1d9f3e2ae46482d6e18253f7e9a3c419f40e746ad2578bbf58c1f56f9a7ec139c9ca5048e2d1a7505002d98b6d54d8906af4f4cfab225d5a09
diff --git a/dev-python/pyscard/pyscard-2.0.8.ebuild b/dev-python/pyscard/pyscard-2.0.8.ebuild
new file mode 100644
index 000000000000..b141ab35e303
--- /dev/null
+++ b/dev-python/pyscard/pyscard-2.0.8.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Smart card support in python"
+HOMEPAGE="
+ https://pyscard.sourceforge.io/
+ https://github.com/LudovicRousseau/pyscard/
+ https://pypi.org/project/pyscard/
+"
+SRC_URI="
+ https://downloads.sourceforge.net/project/pyscard/pyscard/pyscard%20${PV}/${P}.tar.gz
+"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+DEPEND="
+ sys-apps/pcsc-lite
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-lang/swig
+"
+
+distutils_enable_tests unittest
+
+pkg_postinst() {
+ optfeature "Gui support" dev-python/wxpython
+ optfeature "Support of remote readers with Pyro" dev-python/Pyro4
+}
+
+python_test() {
+ cd test || die
+ eunittest
+}