summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-12-19 17:33:10 +0100
committerMichał Górny <mgorny@gentoo.org>2023-12-19 17:33:36 +0100
commit2d51cd50f61b26aa958e448dfb1508c46d08970c (patch)
tree631d19128164011d7917f7e0af18172d4e684678 /dev-python/pyspelling
parentgui-libs/xdg-desktop-portal-wlr: install wlroots-portals.conf (diff)
downloadgentoo-2d51cd50f61b26aa958e448dfb1508c46d08970c.tar.gz
gentoo-2d51cd50f61b26aa958e448dfb1508c46d08970c.tar.bz2
gentoo-2d51cd50f61b26aa958e448dfb1508c46d08970c.zip
dev-python/pyspelling: Add test dep on English dictionaries
Bug: https://bugs.gentoo.org/918329 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyspelling')
-rw-r--r--dev-python/pyspelling/pyspelling-2.9.ebuild10
1 files changed, 7 insertions, 3 deletions
diff --git a/dev-python/pyspelling/pyspelling-2.9.ebuild b/dev-python/pyspelling/pyspelling-2.9.ebuild
index c541c4c3db44..5cb7f5346224 100644
--- a/dev-python/pyspelling/pyspelling-2.9.ebuild
+++ b/dev-python/pyspelling/pyspelling-2.9.ebuild
@@ -40,9 +40,13 @@ RDEPEND="
>=dev-python/soupsieve-1.8[${PYTHON_USEDEP}]
>=dev-python/wcmatch-6.5[${PYTHON_USEDEP}]
"
-
+# The package can use either aspell or hunspell but tests both if both
+# are installed. Therefore, we need to ensure that both have English
+# dictionary installed.
BDEPEND="
test? (
+ app-dicts/aspell-en
+ app-dicts/myspell-en
dev-vcs/git
)
"
@@ -52,11 +56,11 @@ distutils_enable_tests pytest
python_prepare_all() {
# mkdocs-git-revision-date-localized-plugin needs git repo
if use doc; then
- git init || die
+ git init -q || die
git config --global user.email "you@example.com" || die
git config --global user.name "Your Name" || die
git add . || die
- git commit -m 'init' || die
+ git commit -q -m 'init' || die
fi
distutils-r1_python_prepare_all