summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-06-28 19:09:05 +0200
committerMichał Górny <mgorny@gentoo.org>2023-06-28 19:17:30 +0200
commitbfd9fe112a32d8f23cd1cb24b64dd6df57efaa08 (patch)
tree5d3ce9ca86d336bf55629be07ec971e27c1ef1a2 /dev-python/pytest-datafiles/pytest-datafiles-3.0.0.ebuild
parentapp-portage/pycargoebuild: Bump to 0.10 (diff)
downloadgentoo-bfd9fe112a32d8f23cd1cb24b64dd6df57efaa08.tar.gz
gentoo-bfd9fe112a32d8f23cd1cb24b64dd6df57efaa08.tar.bz2
gentoo-bfd9fe112a32d8f23cd1cb24b64dd6df57efaa08.zip
dev-python/pytest-datafiles: New package, v3.0.0
New dependency of dev-python/cx_Freeze. Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-datafiles/pytest-datafiles-3.0.0.ebuild')
-rw-r--r--dev-python/pytest-datafiles/pytest-datafiles-3.0.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/pytest-datafiles/pytest-datafiles-3.0.0.ebuild b/dev-python/pytest-datafiles/pytest-datafiles-3.0.0.ebuild
new file mode 100644
index 000000000000..63e219c09aa8
--- /dev/null
+++ b/dev-python/pytest-datafiles/pytest-datafiles-3.0.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Create a 'tmp_path' containing predefined files/directories"
+HOMEPAGE="
+ https://github.com/omarkohl/pytest-datafiles/
+ https://pypi.org/project/pytest-datafiles/
+"
+SRC_URI="
+ https://github.com/omarkohl/pytest-datafiles/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/pytest-3.6[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest