summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-03-09 21:38:26 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-03-09 22:06:05 +0200
commit15b8eed17887ea5ba34b542a186d196cde573141 (patch)
treeb528feb1d239eff0545496f5c9a353e4ed286b60 /dev-python/pytest-flake8
parentdev-python/pycountry: add 22.3.5 (diff)
downloadgentoo-15b8eed17887ea5ba34b542a186d196cde573141.tar.gz
gentoo-15b8eed17887ea5ba34b542a186d196cde573141.tar.bz2
gentoo-15b8eed17887ea5ba34b542a186d196cde573141.zip
dev-python/pytest-flake8: add 1.1.0
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/pytest-flake8')
-rw-r--r--dev-python/pytest-flake8/Manifest1
-rw-r--r--dev-python/pytest-flake8/pytest-flake8-1.1.0.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/pytest-flake8/Manifest b/dev-python/pytest-flake8/Manifest
index fac0e5aadec9..42eabff6661b 100644
--- a/dev-python/pytest-flake8/Manifest
+++ b/dev-python/pytest-flake8/Manifest
@@ -1 +1,2 @@
DIST pytest-flake8-1.0.7.tar.gz 9560 BLAKE2B 056066a6693fa6988448662e52856eeed49688e834b344e5f60f31f1c3b3ef89043dba06bddbf958b042ab9e702fec056784b252e96c8b4b46fe350a801535cf SHA512 16e7b437ff9fc9afd3520f6b81d9eafeda840c7cd7925f5287ce0e0d5b20a0fa758183cea7ade369e3fec8606eee976e84c5b3142923e4586f559232012bf3a3
+DIST pytest-flake8-1.1.0.tar.gz 9070 BLAKE2B fbf4e0d6480b26729aa43d6d7f05d19950c60b0ad047d5c0a788bccde0bf82805122480575022bb46919599208225f0bcbaf2c4e68d2a875814c1f6540fc35b2 SHA512 3dd060e711d2540e65583b299809c82d70969d3a13e17cb3cc2f7d92e6cfa841ceefb046d4c1a57e9b198b64711114936983d18b9f89ebefa3d5798f5d158215
diff --git a/dev-python/pytest-flake8/pytest-flake8-1.1.0.ebuild b/dev-python/pytest-flake8/pytest-flake8-1.1.0.ebuild
new file mode 100644
index 000000000000..9e196ff22006
--- /dev/null
+++ b/dev-python/pytest-flake8/pytest-flake8-1.1.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="pytest plugin for flake8"
+HOMEPAGE="
+ https://github.com/tholo/pytest-flake8/
+ https://pypi.org/project/pytest-flake8/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~x86"
+
+RDEPEND=">=dev-python/flake8-3.5.0[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest -p flake8
+}