summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVirgil Dupras <vdupras@gentoo.org>2019-06-02 09:30:59 -0400
committerVirgil Dupras <vdupras@gentoo.org>2019-06-02 09:30:59 -0400
commita8c2fb9df70121e653cde6d9d7a14789a54edc1f (patch)
tree29caa9732181f4e3ad4d9ad85c7fd6fea4b0f790 /dev-python/pytest-xdist
parentnet-nds/389-ds-base: Maintainer retired (diff)
downloadgentoo-a8c2fb9df70121e653cde6d9d7a14789a54edc1f.tar.gz
gentoo-a8c2fb9df70121e653cde6d9d7a14789a54edc1f.tar.bz2
gentoo-a8c2fb9df70121e653cde6d9d7a14789a54edc1f.zip
dev-python/pytest-xdist: bump to 1.28.0
Had to drop keywords because of new dev-python/filelock dep. Signed-off-by: Virgil Dupras <vdupras@gentoo.org> Package-Manager: Portage-2.3.66, Repoman-2.3.11
Diffstat (limited to 'dev-python/pytest-xdist')
-rw-r--r--dev-python/pytest-xdist/Manifest1
-rw-r--r--dev-python/pytest-xdist/files/pytest-xdist-1.28.0-strip-setuptools-scm.patch27
-rw-r--r--dev-python/pytest-xdist/pytest-xdist-1.28.0.ebuild38
3 files changed, 66 insertions, 0 deletions
diff --git a/dev-python/pytest-xdist/Manifest b/dev-python/pytest-xdist/Manifest
index b0ea341f170b..ba920c0df35c 100644
--- a/dev-python/pytest-xdist/Manifest
+++ b/dev-python/pytest-xdist/Manifest
@@ -1 +1,2 @@
DIST pytest-xdist-1.23.2.tar.gz 59932 BLAKE2B f2cf73914cf095217fb8b472f5e5f7918435c75f8da1694cc7ceb920ac3a7390d84bea93cca558ba26cf3d14a01815374eab9ea03a137a8a9f5dba2f2d4453a8 SHA512 4aae9a6d74e53a29630d0233d0a903d008023e322de726ef7ab7cf4865f428942f96cc65264e19726cb6213264edaa747da2cb6f368989417ba821f2a3f9b654
+DIST pytest-xdist-1.28.0.tar.gz 61486 BLAKE2B ef8157079ea890342cd566f327588148fa898a3404e3edcffb60ba8ba37d9473b4c2a47fc737f7bb074042c6aadd737ac51f348ce79a718eb446036016cd5e23 SHA512 89b8885103a944ae72535de40028db052f76631ade6f969489d3dc3a1a61a3233df6655d0905d9f5253f23740a15aea824b460c680e79c16f275b31cb2abd6ad
diff --git a/dev-python/pytest-xdist/files/pytest-xdist-1.28.0-strip-setuptools-scm.patch b/dev-python/pytest-xdist/files/pytest-xdist-1.28.0-strip-setuptools-scm.patch
new file mode 100644
index 000000000000..8ef0272d2b5b
--- /dev/null
+++ b/dev-python/pytest-xdist/files/pytest-xdist-1.28.0-strip-setuptools-scm.patch
@@ -0,0 +1,27 @@
+diff --git a/setup.py b/setup.py
+index 17abe9a..81422db 100644
+--- a/setup.py
++++ b/setup.py
+@@ -6,9 +6,13 @@ install_requires = ["execnet>=1.1", "pytest>=4.4.0", "pytest-forked", "six"]
+ with open("README.rst") as f:
+ long_description = f.read()
+
++import os
++with open("xdist/_version.py", 'wt') as fp:
++ fp.write('version = "{}"'.format(os.environ['PV']))
++
+ setup(
+ name="pytest-xdist",
+- use_scm_version={"write_to": "xdist/_version.py"},
++ version=os.environ['PV'],
+ description="pytest xdist plugin for distributed testing"
+ " and loop-on-failing modes",
+ long_description=long_description,
+@@ -24,7 +28,6 @@ setup(
+ zip_safe=False,
+ python_requires=">=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*",
+ install_requires=install_requires,
+- setup_requires=["setuptools_scm"],
+ classifiers=[
+ "Development Status :: 5 - Production/Stable",
+ "Framework :: Pytest",
diff --git a/dev-python/pytest-xdist/pytest-xdist-1.28.0.ebuild b/dev-python/pytest-xdist/pytest-xdist-1.28.0.ebuild
new file mode 100644
index 000000000000..9564d7976934
--- /dev/null
+++ b/dev-python/pytest-xdist/pytest-xdist-1.28.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy{,3} )
+
+inherit distutils-r1
+
+DESCRIPTION="Distributed testing and loop-on-failing modes"
+HOMEPAGE="https://pypi.org/project/pytest-xdist/ https://github.com/pytest-dev/pytest-xdist"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~sparc ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-python/execnet[${PYTHON_USEDEP}]
+ >=dev-python/pytest-4.4[${PYTHON_USEDEP}]
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/filelock[${PYTHON_USEDEP}] )
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.28.0-strip-setuptools-scm.patch"
+)
+
+python_test() {
+ distutils_install_for_testing
+ pytest -vv testing || die "Tests failed under ${EPYTHON}"
+}