summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-24 05:51:27 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-24 08:00:54 +0200
commit878ce8b0679292ae566588e3b48fe9dfd268dbdb (patch)
tree5257c18a98b28e9ca39cf2f2e5d551addd7c17f9 /dev-python/pytest-xprocess
parentapp-admin/awscli: Bump to 1.24.6 (diff)
downloadgentoo-878ce8b0679292ae566588e3b48fe9dfd268dbdb.tar.gz
gentoo-878ce8b0679292ae566588e3b48fe9dfd268dbdb.tar.bz2
gentoo-878ce8b0679292ae566588e3b48fe9dfd268dbdb.zip
dev-python/pytest-xprocess: Bump to 0.19.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-xprocess')
-rw-r--r--dev-python/pytest-xprocess/Manifest1
-rw-r--r--dev-python/pytest-xprocess/pytest-xprocess-0.19.0.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/pytest-xprocess/Manifest b/dev-python/pytest-xprocess/Manifest
index 213fe0d785fa..075506a6b558 100644
--- a/dev-python/pytest-xprocess/Manifest
+++ b/dev-python/pytest-xprocess/Manifest
@@ -1 +1,2 @@
DIST pytest-xprocess-0.18.1.tar.gz 26976 BLAKE2B 9772fff488414406f487add01fba9ee2e10e12965d5b289b8c17cffb5a6566aaea0653ca1b390e6b4c70d79ce3698b0ce8122ed919f9778cb8cf3f7488cffc8d SHA512 f19cba9954e4b2363db13b7dba373f5e50cfca6f43d6455f271bff4d01dcc2a3b15c13a47076dbeed34feffee856a8271df4837edab413e964a848cbb6228e7e
+DIST pytest-xprocess-0.19.0.tar.gz 30217 BLAKE2B 1990a48036469f990451b8eb12a05b7f10295532a72567f95d95d6e12f192f0b76bd511a994c5b8f0e3725f0edb76c4991351fe68e82f351d9b47a9921230f11 SHA512 d41c3c91892d6126455e9b834ada7aad5d0fa67603eff14a73309589e269a21de032e8192e9bde4d6656aaa4984dd0c98242d54b0e2b24a43b85c8ed81a00d89
diff --git a/dev-python/pytest-xprocess/pytest-xprocess-0.19.0.ebuild b/dev-python/pytest-xprocess/pytest-xprocess-0.19.0.ebuild
new file mode 100644
index 000000000000..ad5324f444dd
--- /dev/null
+++ b/dev-python/pytest-xprocess/pytest-xprocess-0.19.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Manage external processes across test runs"
+HOMEPAGE="
+ https://pypi.org/project/pytest-xprocess/
+ https://github.com/pytest-dev/pytest-xprocess/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest