summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-07-12 21:09:56 +0200
committerMichał Górny <mgorny@gentoo.org>2024-07-12 21:26:16 +0200
commitc6d992b2ed85048a3203ee45fdbef8791ce0dcb9 (patch)
tree16c213e8a10116ab6568804411e64a017aea5fae /dev-python/python-augeas/python-augeas-1.1.0-r1.ebuild
parentapp-crypt/certbot: Enable py3.13 (diff)
downloadgentoo-c6d992b2ed85048a3203ee45fdbef8791ce0dcb9.tar.gz
gentoo-c6d992b2ed85048a3203ee45fdbef8791ce0dcb9.tar.bz2
gentoo-c6d992b2ed85048a3203ee45fdbef8791ce0dcb9.zip
dev-python/python-augeas: Enable py3.13
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/python-augeas/python-augeas-1.1.0-r1.ebuild')
-rw-r--r--dev-python/python-augeas/python-augeas-1.1.0-r1.ebuild21
1 files changed, 13 insertions, 8 deletions
diff --git a/dev-python/python-augeas/python-augeas-1.1.0-r1.ebuild b/dev-python/python-augeas/python-augeas-1.1.0-r1.ebuild
index 78f839353bf6..ca40202fd398 100644
--- a/dev-python/python-augeas/python-augeas-1.1.0-r1.ebuild
+++ b/dev-python/python-augeas/python-augeas-1.1.0-r1.ebuild
@@ -5,12 +5,16 @@ EAPI=8
DISTUTILS_USE_PEP517=setuptools
PYPI_NO_NORMALIZE=1
-PYTHON_COMPAT=( python3_{9..12} )
+PYTHON_COMPAT=( python3_{10..13} )
inherit distutils-r1 pypi
DESCRIPTION="Python bindings for Augeas"
-HOMEPAGE="http://augeas.net/"
+HOMEPAGE="
+ http://augeas.net/
+ https://github.com/hercules-team/python-augeas/
+ https://pypi.org/project/python-augeas/
+"
LICENSE="LGPL-2.1"
SLOT="0"
@@ -20,11 +24,12 @@ RDEPEND="
app-admin/augeas
>=dev-python/cffi-1.0.0[${PYTHON_USEDEP}]
"
-DEPEND="${RDEPEND}"
+BDEPEND="
+ ${RDEPEND}
+"
-PATCHES=( "${FILESDIR}/remove-tests.patch" )
+PATCHES=(
+ "${FILESDIR}/remove-tests.patch"
+)
-python_test() {
- cd test || die
- "${EPYTHON}" test_augeas.py || die "Tests failed with ${EPYTHON}"
-}
+distutils_enable_tests unittest