summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2019-04-10 16:40:16 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2019-04-10 17:43:25 -0500
commit8efeb43ccf5e073135c804601baa796ef166dd4f (patch)
treebf857ff704dc8ae9756bc92bdb82bd5f5abfd533 /dev-python/python-barbicanclient/python-barbicanclient-4.8.1.ebuild
parentdev-python/psutil: 5.6.0 bump (diff)
downloadgentoo-8efeb43ccf5e073135c804601baa796ef166dd4f.tar.gz
gentoo-8efeb43ccf5e073135c804601baa796ef166dd4f.tar.bz2
gentoo-8efeb43ccf5e073135c804601baa796ef166dd4f.zip
dev-python/python-barbicanclient: 4.8.1 bump
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-python/python-barbicanclient/python-barbicanclient-4.8.1.ebuild')
-rw-r--r--dev-python/python-barbicanclient/python-barbicanclient-4.8.1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/python-barbicanclient/python-barbicanclient-4.8.1.ebuild b/dev-python/python-barbicanclient/python-barbicanclient-4.8.1.ebuild
new file mode 100644
index 000000000000..8b115b8b5e20
--- /dev/null
+++ b/dev-python/python-barbicanclient/python-barbicanclient-4.8.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Client library for Barbican API."
+HOMEPAGE="https://github.com/openstack/barbican"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}
+"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/requests-2.14.2[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/cliff-2.8.0[${PYTHON_USEDEP}]
+ !~dev-python/cliff-2.9.0[${PYTHON_USEDEP}]
+ >=dev-python/keystoneauth-3.4.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
+ >=dev-python/oslo-serialization-1.18.0[${PYTHON_USEDEP}]
+ !~dev-python/oslo-serialization-1.19.1[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}]
+"