summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-10-24 22:00:34 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-10-24 22:00:34 +0300
commitc4f26add0ba47694b07512709988357fa5b57ce1 (patch)
tree6db19f0f29b76464cccad8b01598e84283e95884 /dev-python/python-cstruct
parentdev-python/brython: add 3.11 (diff)
downloadgentoo-c4f26add0ba47694b07512709988357fa5b57ce1.tar.gz
gentoo-c4f26add0ba47694b07512709988357fa5b57ce1.tar.bz2
gentoo-c4f26add0ba47694b07512709988357fa5b57ce1.zip
dev-python/python-cstruct: add 3.3
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/python-cstruct')
-rw-r--r--dev-python/python-cstruct/Manifest1
-rw-r--r--dev-python/python-cstruct/python-cstruct-3.3.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/python-cstruct/Manifest b/dev-python/python-cstruct/Manifest
index 278b7ef5c8ea..a6644c7a088e 100644
--- a/dev-python/python-cstruct/Manifest
+++ b/dev-python/python-cstruct/Manifest
@@ -1,3 +1,4 @@
DIST python-cstruct-3.0.gh.tar.gz 25950 BLAKE2B 7ea8c77ed87e4fb740c3f7a4ed53a7532ee5aca15ee46fbb40da7308ae62ceacd7ccc67a958e6355904604ae67c9594acc9cae5d18bfed0558b91f7e9c8ad0a9 SHA512 dd1c85363512edc4df0379dec40e7d7fe3ceff1cc4014eae8dab0e91c47ea9c3619211e1a637aeec134ce713d0681688630b7fde97f02c6bcd7103a32f258a73
DIST python-cstruct-3.1.gh.tar.gz 26633 BLAKE2B 449510cc8cc6661270d2618cd347eea2044eacc8f665ed2f55bc6fcd95bcf79f29f8bce6498d372d8b5b78f854edb06afb89a3f3ef7f5de37582ebf68d178db1 SHA512 00e2165c14dcc4461600a8eeef5c71bcaa6e59955c23d08055aff2186b16f20d6c10fdb1a02f6e263e27070fda562c712df0c4ad2440a25dc5f23afaa9c88719
DIST python-cstruct-3.2.gh.tar.gz 26876 BLAKE2B 084c4e3e1e5a48ee15c40e25a846b09dc1af1fe0ef9734bddad14ebac91e2bbdf78cffc39dd861f35d7ed307f1dfb14cb7b15dd47b900d3c943bf3245adb9ff3 SHA512 8b912bba7a31a8cacd77e07008ea1a0603c59c49e2cbb4a8fee158948b05166f2223c983f58c104d73c0fd868bfaebc9f38669277f27282486cfb064d9026ab5
+DIST python-cstruct-3.3.gh.tar.gz 27470 BLAKE2B 0403af7085622e26d5faf973bbfd0c7e35f5c51f0597abf079080800055058809a07a795bde37b796809ef13b6e1d030f36a42e45a7f4643202e37fe79df4730 SHA512 fd5d7d42f5458d37a44d5e792b56e5c4f3338ed656b248ec5f4f48e4ecb5b6be7e3561c697d67ce0c6a18fbef62ba4945e287754cb2d6a97fefd65c563d65774
diff --git a/dev-python/python-cstruct/python-cstruct-3.3.ebuild b/dev-python/python-cstruct/python-cstruct-3.3.ebuild
new file mode 100644
index 000000000000..7b8d01c50942
--- /dev/null
+++ b/dev-python/python-cstruct/python-cstruct-3.3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+inherit distutils-r1
+
+DESCRIPTION="C-style structs for Python"
+HOMEPAGE="https://github.com/andreax79/python-cstruct
+ https://pypi.org/project/cstruct/"
+SRC_URI="
+ https://github.com/andreax79/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DOCS=( README.md )
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ distutils-r1_src_prepare
+
+ sed -e "/find_packages(/s@exclude=\[@&'tests', @" -i setup.py || die
+}